summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2020-02-24 16:29:10 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-05 13:58:30 +0200
commitc276f515d7c110e1fe3e1b20520ffa3fa5bbb942 (patch)
tree0639e78d9e3808f4cecc7d19098fa5610b009460 /mail-client
parentmail-client/alot: version bump 0.9 (diff)
downloadgentoo-c276f515d7c110e1fe3e1b20520ffa3fa5bbb942.tar.gz
gentoo-c276f515d7c110e1fe3e1b20520ffa3fa5bbb942.tar.bz2
gentoo-c276f515d7c110e1fe3e1b20520ffa3fa5bbb942.zip
mail-client/alot: Upgrade live-ebuild
Closes: https://bugs.gentoo.org/710610 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14756 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/alot-9999.ebuild40
1 files changed, 13 insertions, 27 deletions
diff --git a/mail-client/alot/alot-9999.ebuild b/mail-client/alot/alot-9999.ebuild
index 616f650d4ec8..9d12b1946481 100644
--- a/mail-client/alot/alot-9999.ebuild
+++ b/mail-client/alot/alot-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -24,17 +25,16 @@ IUSE="doc test"
RESTRICT="!test? ( test )"
RDEPEND="
- >=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
- >=dev-python/configobj-4.7.0[${PYTHON_USEDEP}]
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
dev-python/python-magic[${PYTHON_USEDEP}]
- >=dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
>=dev-python/twisted-18.4[${PYTHON_USEDEP}]
net-mail/mailbase
- >=net-mail/notmuch-0.27[crypt,python]
+ net-mail/notmuch[crypt,python]
"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
${RDEPEND}
@@ -44,20 +44,19 @@ DEPEND="
PATCHES=(
"${FILESDIR}/${PV}-0001-remove-non-working-test.patch"
+ "${FILESDIR}/${PV}-0002-update-reference-to-envelope-body.patch"
)
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/build/html/. )
- fi
-}
+distutils_enable_tests setup.py
-src_test() {
- esetup.py test
+python_compile_all() {
+ emake -C docs man
+ use doc && emake -C docs html
}
python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ doman docs/build/man/*
distutils-r1_python_install_all
insinto /usr/share/alot
@@ -71,18 +70,5 @@ pkg_postinst() {
elog "the user manual:"
elog " https://alot.readthedocs.io/en/latest/"
elog ""
- else
- local rv
- for rv in ${REPLACING_VERSIONS} ; do
- if ver_test "${rv}" -le "0.5.1"; then
- ewarn ""
- ewarn "Since 0.6 version the GPG engine has switched to app-crypt/gpgme"
- ewarn "to use GPG signing operations, you can pass the key id has arg"
- ewarn "or setup the gpg_key value in your config file, see"
- ewarn " https://alot.readthedocs.io/en/latest/usage/crypto.html?highlight=gpg"
- ewarn ""
- break
- fi
- done
fi
}