summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2020-03-13 22:31:47 +0100
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2020-03-18 22:21:26 +0000
commit9d2497303272322c7fc4e37ebe7f729df2b327ba (patch)
tree0197f29e5efb4ec379d768d0f4f1f5ef46abd365 /mail-filter/afew/afew-2.0.0.ebuild
parentmail-filter/afew: Add myself to maintainer (diff)
downloadgentoo-9d2497303272322c7fc4e37ebe7f729df2b327ba.tar.gz
gentoo-9d2497303272322c7fc4e37ebe7f729df2b327ba.tar.bz2
gentoo-9d2497303272322c7fc4e37ebe7f729df2b327ba.zip
mail-filter/afew: Add version bump 2.0.0
Closes: https://bugs.gentoo.org/712426 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Diffstat (limited to 'mail-filter/afew/afew-2.0.0.ebuild')
-rw-r--r--mail-filter/afew/afew-2.0.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/mail-filter/afew/afew-2.0.0.ebuild b/mail-filter/afew/afew-2.0.0.ebuild
new file mode 100644
index 000000000000..b9e74273e201
--- /dev/null
+++ b/mail-filter/afew/afew-2.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Initial tagging script for Notmuch"
+HOMEPAGE="https://github.com/afewmail/afew"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/dkimpy[${PYTHON_MULTI_USEDEP}]
+ net-mail/notmuch[python,${PYTHON_MULTI_USEDEP}]
+ ')"
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+DOCS=( "README.rst" )
+
+python_prepare_all() {
+ sed -r \
+ -e "s/^([[:space:]]+)use_scm_version=.*,$/\1version='${PV}',/" \
+ -e "/^([[:space:]]+)setup_requires=.*,$/d" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ esetup.py build_sphinx -b man --build-dir=docs/build
+ use doc && esetup.py build_sphinx -b html --build-dir=docs/build
+}
+
+python_install_all() {
+ doman docs/build/man/*
+ dodoc afew/defaults/afew.config
+ use doc && local HTML_DOCS=( docs/build/html/. )
+}