summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-16 21:46:07 +0000
committerSam James <sam@gentoo.org>2020-09-16 21:53:43 +0000
commiteb6ab9171bc7e9480fb6b19b1be3ff69a3bd2457 (patch)
treee8f4a63782065acc3691a495b695c708809598c4 /mail-filter/mapson
parentsci-chemistry/raster3d: Remove old 3.0.2, 3.0.3 (diff)
downloadgentoo-eb6ab9171bc7e9480fb6b19b1be3ff69a3bd2457.tar.gz
gentoo-eb6ab9171bc7e9480fb6b19b1be3ff69a3bd2457.tar.bz2
gentoo-eb6ab9171bc7e9480fb6b19b1be3ff69a3bd2457.zip
mail-filter/mapson: port to EAPI 7
Closes: https://bugs.gentoo.org/476576 Closes: https://bugs.gentoo.org/513896 Closes: https://bugs.gentoo.org/741034 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-filter/mapson')
-rw-r--r--mail-filter/mapson/files/mapson-3.3-respect-AR.patch12
-rw-r--r--mail-filter/mapson/mapson-3.3-r1.ebuild (renamed from mail-filter/mapson/mapson-3.3.ebuild)35
2 files changed, 36 insertions, 11 deletions
diff --git a/mail-filter/mapson/files/mapson-3.3-respect-AR.patch b/mail-filter/mapson/files/mapson-3.3-respect-AR.patch
new file mode 100644
index 000000000000..7a5ecaae5d3f
--- /dev/null
+++ b/mail-filter/mapson/files/mapson-3.3-respect-AR.patch
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index 8dc1878..3967624 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,6 +25,7 @@ AM_PROG_CC_C_O
+ AC_PROG_CXX
+ AC_PROG_RANLIB
+ gl_INIT
++AM_PROG_AR
+
+ dnl Does the system have a working <getopt.h> include and
+ dnl getopt_long() function?
diff --git a/mail-filter/mapson/mapson-3.3.ebuild b/mail-filter/mapson/mapson-3.3-r1.ebuild
index 5c6ce7bac660..9903dbb7f789 100644
--- a/mail-filter/mapson/mapson-3.3.ebuild
+++ b/mail-filter/mapson/mapson-3.3-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="A challenge/response-based white-list spam filter"
HOMEPAGE="http://mapson.sourceforge.net/"
@@ -13,11 +14,20 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug"
-RDEPEND="virtual/mta"
+RDEPEND="
+ acct-user/mail
+ virtual/mta
+"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3-gcc6.patch
+ "${FILESDIR}"/${PN}-3.3-respect-AR.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc6.patch
+ default
+ eautoreconf
}
src_configure() {
@@ -25,17 +35,20 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
dodoc AUTHORS INSTALL NEWS README
doman doc/mapson.1
- dohtml doc/mapson.html
- dodir /etc/mapson
+
+ docinto html
+ dodoc doc/mapson.html
+
insinto /etc/mapson
newins sample-config mapson.config
- dodir /usr/share/mapson
+
insinto /usr/share/mapson
newins sample-challenge-template challenge-template
- rm -f "${D}"/etc/sample-config
- rm -f "${D}"/usr/share/{mapson.html,sample-challenge-template}
+
+ rm -f "${ED}"/etc/sample-config || die
+ rm -f "${ED}"/usr/share/{mapson.html,sample-challenge-template} || die
}