summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-05-16 08:34:54 +0200
committerFabian Groffen <grobian@gentoo.org>2017-05-16 08:34:54 +0200
commitc60b2cb3961f35c056ede5fe3ab261c00720e4b4 (patch)
tree6e8eb338ec7e684ba8a4eab27296506991b9f75a /mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild
parentdev-ruby/systemu: add ruby24 (diff)
downloadgentoo-c60b2cb3961f35c056ede5fe3ab261c00720e4b4.tar.gz
gentoo-c60b2cb3961f35c056ede5fe3ab261c00720e4b4.tar.bz2
gentoo-c60b2cb3961f35c056ede5fe3ab261c00720e4b4.zip
mail-filter/opendmarc: ensure we don't use bundled libspf, thanks Richard Hering, bug #618284
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild')
-rw-r--r--mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild b/mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..50e8bb5bf2de
--- /dev/null
+++ b/mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="Open source DMARC implementation "
+HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
+SRC_URI="mirror://sourceforge/opendmarc/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~x86 ~x86-fbsd"
+IUSE="spf"
+
+DEPEND="dev-perl/DBI
+ || ( mail-filter/libmilter mail-mta/sendmail )"
+RDEPEND="${DEPEND}
+ dev-perl/HTTP-Message
+ dev-perl/Switch
+ spf? ( mail-filter/libspf2 )"
+
+pkg_setup() {
+ enewgroup milter
+ enewuser milter -1 -1 /var/lib/milter milter
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ $(use_with spf) \
+ $(use_with spf spf2-include "${EPREFIX}"/usr/include/spf2) \
+ $(use_with spf spf2-lib "${EPREFIX}"/usr/lib)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/opendmarc.initd opendmarc
+ newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+
+ dodir /etc/opendmarc
+
+ # create config file
+ sed \
+ -e 's:^# UserID .*$:UserID milter:' \
+ -e "s:^# PidFile .*:PidFile ${EPREFIX}/var/run/opendmarc/opendmarc.pid:" \
+ -e '/^# Socket /s:^# ::' \
+ "${S}"/opendmarc/opendmarc.conf.sample \
+ > "${ED}"/etc/opendmarc/opendmarc.conf \
+ || die
+}