summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/zdkimfilter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/zdkimfilter')
-rw-r--r--mail-filter/zdkimfilter/Manifest1
-rw-r--r--mail-filter/zdkimfilter/metadata.xml20
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild48
3 files changed, 69 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/Manifest b/mail-filter/zdkimfilter/Manifest
new file mode 100644
index 000000000000..187e1aeec234
--- /dev/null
+++ b/mail-filter/zdkimfilter/Manifest
@@ -0,0 +1 @@
+DIST zdkimfilter-1.1.tar.gz 473348 SHA256 be55fae98c3e7826a00f74896b91b625fe436aaf94bc2dc7d4770f64f98f2100 SHA512 6f1c54fe22f0c3cb3aaa347df89c0541b7f06dc68c80820820dd80d3ee46e6c2a369efb70d2eab217564728adc17086c76c878c58be13735c1db14d069832cfb WHIRLPOOL 6490a76dc17ee976b36ae3e0a9412e9fdc6b8236be56998e3a322fb35d2cfd84aca33e77c256fa01a54b9ca8e5b9cab75695ff695ad3b90bfade5e118faa8de8
diff --git a/mail-filter/zdkimfilter/metadata.xml b/mail-filter/zdkimfilter/metadata.xml
new file mode 100644
index 000000000000..f2b07819df0d
--- /dev/null
+++ b/mail-filter/zdkimfilter/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<longdescription>A program implementing the DKIM signing/verification for Courier
+</longdescription>
+<use>
+ <flag name='debug'>
+ Log process and signal information. Also leave the child process running for
+ gdb examination.
+ </flag>
+</use>
+<use>
+ <flag name='opendbx'>
+ An alternate statistics based storage engine.
+ </flag>
+</use>
+
+
+</pkgmetadata>
diff --git a/mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild b/mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild
new file mode 100644
index 000000000000..76dffac0eb6f
--- /dev/null
+++ b/mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DESCRIPTION="DKIM filter for Courier-MTA"
+HOMEPAGE="http://www.tana.it/sw/zdkimfilter"
+SRC_URI="http://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opendbx"
+
+DEPEND=">=mail-filter/opendkim-2.2.0
+ mail-mta/courier
+ opendbx? ( >=dev-db/opendbx-1.4.0 )
+ dev-libs/nettle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use opendbx; then
+ # remove opendbx stuff
+ sed -i -e '12342,12450d' configure || die
+ fi
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}"/etc/courier/filters/zdkimfilter.conf || die
+ diropts -o mail -g mail
+ dodir /etc/courier/filters/keys
+ dodoc release-notes-*.txt
+ dodoc odbx_example.{conf,sql}
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} == 0.5 ]]; then
+ ewarn "Database access is now through opendbx. Please see the"
+ ewarn "zfilter_db man page and example config files in"
+ ewarn "\t/usr/share/doc/${P}"
+ ewarn "Some config file options have changed. Please see the"
+ ewarn "release-notes."
+ fi
+}