summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2023-03-10 21:42:59 +0100
committerHanno Böck <hanno@gentoo.org>2023-03-10 21:42:59 +0100
commit1f8b0de60f5abf4d590b98c0d0b110673a2fa719 (patch)
treeb3358043c63cad2f3d90a34241b825eecfa40c6c /mail-filter
parentdev-ruby/text: enable ruby32 (diff)
downloadgentoo-1f8b0de60f5abf4d590b98c0d0b110673a2fa719.tar.gz
gentoo-1f8b0de60f5abf4d590b98c0d0b110673a2fa719.tar.bz2
gentoo-1f8b0de60f5abf4d590b98c0d0b110673a2fa719.zip
mail-filter/zdkimfilter: add 3.14
Signed-off-by: Hanno Böck <hanno@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/zdkimfilter/Manifest1
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-3.14.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/Manifest b/mail-filter/zdkimfilter/Manifest
index 9dc46e690f45..8ebdf2f74e31 100644
--- a/mail-filter/zdkimfilter/Manifest
+++ b/mail-filter/zdkimfilter/Manifest
@@ -1 +1,2 @@
DIST zdkimfilter-3.13.tar.gz 928058 BLAKE2B 70e16bb9063e966b03d5fd96b8ec458cf5451bb7ce3941539687897a6ad5446a05a8da54a129352ada98b9ed9d4412f3534e189034e9b2507ffe22d0aecf5f1d SHA512 1d3a5d1e5b9f8d56f6a03dd08c09ac7ee52fc9af0d305da3965fbd59e6dffcc85238f448df6746ad4f692dfe2bc928a1209ca6630c63ee3c378cb2660f019ce4
+DIST zdkimfilter-3.14.tar.gz 937212 BLAKE2B 93a7e74ad347d171527c24d0f9ee8c38895607ebb3bf08505eef1083cc63d199f82f98d45b9537ecd60e46716f9601694fc8df9d1a96dfd5f7ce74f1646c13ab SHA512 3d8fa2955fe4c61de961d5396a14cdfd60e7df4c48b19dcdc283688192693ad4876ce470a2e9de18292f3addb7f9c2fed3586e4fe11ab3a362456af7c036eb1b
diff --git a/mail-filter/zdkimfilter/zdkimfilter-3.14.ebuild b/mail-filter/zdkimfilter/zdkimfilter-3.14.ebuild
new file mode 100644
index 000000000000..495b98b46cd9
--- /dev/null
+++ b/mail-filter/zdkimfilter/zdkimfilter-3.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DESCRIPTION="DKIM filter for Courier-MTA"
+HOMEPAGE="https://www.tana.it/sw/zdkimfilter"
+SRC_URI="https://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="net-libs/gnutls
+ mail-mta/courier
+ dev-db/opendbx
+ dev-libs/nettle:=
+ net-dns/libidn2:=
+ dev-libs/libunistring:=
+ dev-libs/libbsd"
+RDEPEND="${DEPEND}"
+
+# Tests don't work with portage sandbox
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ diropts -o mail -g mail
+ dodir /etc/courier/filters/keys
+ dodoc release-notes-*.txt README ChangeLog
+ dodoc odbx_example.{conf,sql}
+}