summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-04-30 20:40:18 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-04-30 23:38:09 -0400
commitcdd295d9bdd2a99fb9d9a42b5d58988939479e6f (patch)
treedde7e782dbdd730ef92bd1300a76707f3d6689b1 /mail-filter
parentapp-emulation/wine-staging: Drop old (diff)
downloadgentoo-cdd295d9bdd2a99fb9d9a42b5d58988939479e6f.tar.gz
gentoo-cdd295d9bdd2a99fb9d9a42b5d58988939479e6f.tar.bz2
gentoo-cdd295d9bdd2a99fb9d9a42b5d58988939479e6f.zip
mail-filter/opendkim: new revision with missing test dependency.
The OpenDKIM test suite won't be run if the user doesn't have Lua installed. The (R)DEPEND variables have been refactored to add that missing build-time dependency. In addition, a hacky sed line that relocated the unix socket in the test suite has been replaced, by the --with-test-socket ./configure flag. Bug: https://bugs.gentoo.org/682290 Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendkim/opendkim-2.10.3-r13.ebuild (renamed from mail-filter/opendkim/opendkim-2.10.3-r12.ebuild)24
1 files changed, 14 insertions, 10 deletions
diff --git a/mail-filter/opendkim/opendkim-2.10.3-r12.ebuild b/mail-filter/opendkim/opendkim-2.10.3-r13.ebuild
index ee5908da59c4..037a1b0f98cd 100644
--- a/mail-filter/opendkim/opendkim-2.10.3-r12.ebuild
+++ b/mail-filter/opendkim/opendkim-2.10.3-r13.ebuild
@@ -13,9 +13,9 @@ SRC_URI="mirror://sourceforge/opendkim/${P}.tar.gz"
LICENSE="BSD GPL-2 Sendmail-Open-Source"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+berkdb ldap libressl lmdb lua memcached opendbx poll sasl selinux +ssl static-libs unbound"
+IUSE="+berkdb ldap libressl lmdb lua memcached opendbx poll sasl selinux +ssl static-libs test unbound"
-DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )
+COMMON_DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )
dev-libs/libbsd
sys-apps/grep
ssl? (
@@ -32,7 +32,10 @@ DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )
unbound? ( >=net-dns/unbound-1.4.1:= net-dns/dnssec-root )
!unbound? ( net-libs/ldns )"
-RDEPEND="${DEPEND}
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-lang/lua:* )"
+
+RDEPEND="${COMMON_DEPEND}
sys-process/psmisc
selinux? ( sec-policy/selinux-dkim )"
@@ -52,12 +55,12 @@ pkg_setup() {
src_prepare() {
default
- sed -i -e 's:/var/db/dkim:/var/lib/opendkim:g' \
- opendkim/opendkim.conf.sample opendkim/opendkim.conf.simple.in || die
- sed -i -e 's:dist_doc_DATA:dist_html_DATA:' libopendkim/docs/Makefile.am || die
- # TODO: what purpose does this serve?
- sed -i -e "/sock.*mt.getcwd/s:mt.getcwd():${T}:" \
- opendkim/tests/*.lua || die
+ sed -e 's:/var/db/dkim:/var/lib/opendkim:g' \
+ -i opendkim/opendkim.conf.sample opendkim/opendkim.conf.simple.in \
+ || die
+ sed -e 's:dist_doc_DATA:dist_html_DATA:' \
+ -i libopendkim/docs/Makefile.am \
+ || die
eautoreconf
}
@@ -106,7 +109,8 @@ src_configure() {
--enable-default_sender \
--enable-sender_macro \
--enable-vbr \
- --disable-live-testing
+ --disable-live-testing \
+ --with-test-socket="${T}/opendkim.sock"
}
src_compile() {