summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-05-08 10:23:13 +0200
committerFabian Groffen <grobian@gentoo.org>2021-05-08 10:23:19 +0200
commit9a3e0eda4fc04c85c612ee6cdfd45e26e9108209 (patch)
tree342c9932f280f7bc167fcd99d20feb0555bbc533 /mail-mta/exim
parentmail-filter/opendmarc-1.4.1.1: revbump to allow SLOT recompiles (diff)
downloadgentoo-9a3e0eda4fc04c85c612ee6cdfd45e26e9108209.tar.gz
gentoo-9a3e0eda4fc04c85c612ee6cdfd45e26e9108209.tar.bz2
gentoo-9a3e0eda4fc04c85c612ee6cdfd45e26e9108209.zip
mail-mta/exim: bump stable release to include SLOT dep for opendmarc
Unfortunately opendmarc broke their API without telling, and we need to ensure Exim instances are rebuilt that link against an upgraded opendmarc. Also, need to ensure that once opendmarc-1.4 goes stable, Exim is properly rebuilt. Unfortunately this requires a conditional patch, so we're all extremely unhappy here. Closes: https://bugs.gentoo.org/788343 Package-Manager: Portage-3.0.18, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'mail-mta/exim')
-rw-r--r--mail-mta/exim/exim-4.94.2-r1.ebuild (renamed from mail-mta/exim/exim-4.94.2.ebuild)8
-rw-r--r--mail-mta/exim/files/exim-4.94-opendmarc-1.4.patch14
2 files changed, 21 insertions, 1 deletions
diff --git a/mail-mta/exim/exim-4.94.2.ebuild b/mail-mta/exim/exim-4.94.2-r1.ebuild
index 6458d4525357..6d46c0ba652e 100644
--- a/mail-mta/exim/exim-4.94.2.ebuild
+++ b/mail-mta/exim/exim-4.94.2-r1.ebuild
@@ -69,7 +69,7 @@ COMMON_DEPEND=">=sys-apps/sed-4.0.5
sasl? ( >=dev-libs/cyrus-sasl-2.1.26-r2 )
redis? ( dev-libs/hiredis )
spf? ( >=mail-filter/libspf2-1.2.5-r1 )
- dmarc? ( mail-filter/opendmarc )
+ dmarc? ( mail-filter/opendmarc:= )
srs? ( srs-alt? ( mail-filter/libsrs_alt ) )
X? (
x11-libs/libX11
@@ -117,6 +117,12 @@ src_prepare() {
eapply "${FILESDIR}"/exim-4.69-r1.27021.patch
eapply "${FILESDIR}"/exim-4.94-localscan_dlopen.patch
+ # for this reason we have a := dep on opendmarc, they changed their
+ # API in a minor release
+ if use dmarc && has_version ">=mail-filter/opendmarc-1.4" ; then
+ eapply "${FILESDIR}"/exim-4.94-opendmarc-1.4.patch
+ fi
+
if use maildir ; then
eapply "${FILESDIR}"/exim-4.94-maildir.patch
else
diff --git a/mail-mta/exim/files/exim-4.94-opendmarc-1.4.patch b/mail-mta/exim/files/exim-4.94-opendmarc-1.4.patch
new file mode 100644
index 000000000000..d37c320d1592
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.94-opendmarc-1.4.patch
@@ -0,0 +1,14 @@
+https://bugs.exim.org/show_bug.cgi?id=2728
+
+
+--- a/src/dmarc.c
++++ b/src/dmarc.c
+@@ -446,7 +446,7 @@
+ vs == PDKIM_VERIFY_INVALID ? DMARC_POLICY_DKIM_OUTCOME_TMPFAIL :
+ DMARC_POLICY_DKIM_OUTCOME_NONE;
+ libdm_status = opendmarc_policy_store_dkim(dmarc_pctx, US sig->domain,
+- dkim_result, US"");
++ sig->selector, dkim_result, US"");
+ DEBUG(D_receive)
+ debug_printf("DMARC adding DKIM sender domain = %s\n", sig->domain);
+ if (libdm_status != DMARC_PARSE_OKAY)