summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-03-15 09:32:00 +0100
committerFabian Groffen <grobian@gentoo.org>2020-03-15 09:32:36 +0100
commitaff1b0cb03abb3466ca6aebe7de96510d933dd1b (patch)
treedfef8d2897aeb95230c6c319d5d459dd21960116 /mail-mta
parentprofiles: package.mask cleanup (diff)
downloadgentoo-aff1b0cb03abb3466ca6aebe7de96510d933dd1b.tar.gz
gentoo-aff1b0cb03abb3466ca6aebe7de96510d933dd1b.tar.bz2
gentoo-aff1b0cb03abb3466ca6aebe7de96510d933dd1b.zip
mail-mta/exim-4.93.0.4: reflect DANE default in USE-flags
As pointed out by Hans F. Nordhaug in bug #712360, the configuration for Exim has changed to default to DANE, because TLS (ssl) is enabled by default as well. We handled the latter already, but didn't do the former, resulting in build failures with TLS disabled. Rework the logic such that we USE-enable dane (to reflect upstream) and that we disable it when not enabled. Closes: https://bugs.gentoo.org/712360 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/exim/exim-4.93.0.4.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/mail-mta/exim/exim-4.93.0.4.ebuild b/mail-mta/exim/exim-4.93.0.4.ebuild
index 2fcf22048a1c..a7ac64a9ffb4 100644
--- a/mail-mta/exim/exim-4.93.0.4.ebuild
+++ b/mail-mta/exim/exim-4.93.0.4.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
inherit db-use toolchain-funcs multilib pam systemd
-IUSE="arc dane dcc +dkim dlfunc dmarc +dnsdb doc dovecot-sasl dsn elibc_glibc exiscan-acl gnutls idn ipv6 ldap libressl lmtp maildir mbx mysql nis pam perl pkcs11 postgres +prdr proxy radius redis sasl selinux spf sqlite srs +ssl syslog tcpd +tpda X"
+IUSE="arc +dane dcc +dkim dlfunc dmarc +dnsdb doc dovecot-sasl dsn elibc_glibc exiscan-acl gnutls idn ipv6 ldap libressl lmtp maildir mbx mysql nis pam perl pkcs11 postgres +prdr proxy radius redis sasl selinux spf sqlite srs +ssl syslog tcpd +tpda X"
REQUIRED_USE="
arc? ( dkim spf )
dane? ( ssl !gnutls )
@@ -149,7 +149,7 @@ src_configure() {
local conffile="${EPREFIX}/etc/exim/exim.conf"
sed -e "48i\CFLAGS=${CFLAGS}" \
-e "s:BIN_DIRECTORY=/usr/exim/bin:BIN_DIRECTORY=${EPREFIX}/usr/sbin:" \
- -e "s:EXIM_USER=:EXIM_USER=${MAILUSER}:" \
+ -e "s;EXIM_USER=;EXIM_USER=ref:${MAILUSER};" \
-e "s:CONFIGURE_FILE=.*$:CONFIGURE_FILE=${conffile}:" \
-e "s:ZCAT_COMMAND=.*$:ZCAT_COMMAND=${EPREFIX}/bin/zcat:" \
-e "s:COMPRESS_COMMAND=.*$:COMPRESS_COMMAND=${EPREFIX}/bin/gzip:" \
@@ -166,8 +166,11 @@ src_configure() {
EOC
# if we use libiconv, now is the time to tell so
- use !elibc_glibc && use !elibc_musl && \
- echo "EXTRALIBS_EXIM=-liconv" >> Makefile
+ if use !elibc_glibc && use !elibc_musl ; then
+ cat >> Makefile <<- EOC
+ EXTRALIBS_EXIM=-liconv
+ EOC
+ fi
# support for IPv6
if use ipv6; then
@@ -392,10 +395,9 @@ src_configure() {
fi
# DANE
- if use dane; then
- cat >> Makefile <<- EOC
- SUPPORT_DANE=yes
- EOC
+ if use !dane; then
+ # DANE is enabled by default
+ sed -i -e 's:^SUPPORT_DANE=yes:# SUPPORT_DANE=yes:' Makefile || die
fi
# DMARC