summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-21 22:58:51 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-21 23:02:50 +0100
commitebf9fb9ff79e45b67cd66054bd3d509cb387d8b0 (patch)
tree2244031fd6a0dd8f7ad154dad47e343fce91e297 /mail-mta
parentsys-apps/fwupd: drop 1.8.16 (diff)
downloadgentoo-ebf9fb9ff79e45b67cd66054bd3d509cb387d8b0.tar.gz
gentoo-ebf9fb9ff79e45b67cd66054bd3d509cb387d8b0.tar.bz2
gentoo-ebf9fb9ff79e45b67cd66054bd3d509cb387d8b0.zip
mail-mta/proton-mail-bridge: add 3.3.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/proton-mail-bridge/Manifest2
-rw-r--r--mail-mta/proton-mail-bridge/files/proton-mail-bridge-3.3.2-telemetry_default.patch14
-rw-r--r--mail-mta/proton-mail-bridge/proton-mail-bridge-3.3.2.ebuild84
3 files changed, 100 insertions, 0 deletions
diff --git a/mail-mta/proton-mail-bridge/Manifest b/mail-mta/proton-mail-bridge/Manifest
index cda1f48f641e..b9e6820cb224 100644
--- a/mail-mta/proton-mail-bridge/Manifest
+++ b/mail-mta/proton-mail-bridge/Manifest
@@ -1,2 +1,4 @@
DIST proton-mail-bridge-3.1.3-deps.tar.xz 206716212 BLAKE2B 4f79e4428ef37452d0abd288e074ecdce8886393582352117b6df5275e1b2f0f8018145c20b8fa889f6473899fd0fde6b621e52cf2faaa218fdac8238134a19b SHA512 fd948e39afaab15d7318c8b46cffd97823857cd8e1c5ba2b2ed3673fcbf186627b190bd876973fbb71854355f4dfba62663e902651716301685dca5f14f26e81
DIST proton-mail-bridge-3.1.3.tar.gz 4443963 BLAKE2B 2c8fc571612c11c0e281e8f268774e886ba3742b696bdd1180d7cf45525d21d9c062cd3d33acb57a6ceed8dad6b864490c89c090ebfd4bceb4e8c41b19015ae8 SHA512 4f4ca3a2b95c7eed34a13d7f8f296d95717b9c1f95bd157e08c3f21cc752ea3dac5eaefac27662f57f875d9690a5d77a9e15f71406280dcaad6f9054b2ef54b9
+DIST proton-mail-bridge-3.3.2-deps.tar.xz 252980292 BLAKE2B 2d7c8961c1ed8a6fb15a26f6b3ee650932b89626c0eea1d3acaf24b5ef6b44a90cb021a051a5f018cf94db5ccb029c4b79390275bca9a39ceeb6b5ef62aa1386 SHA512 52ff54e80635e795462e0bdbd5e02b831478a49225d296ec46ef5591cef173c49bcf63d925d503537d57ccaf65a09424f82d1c8ad8e906d822306ca22bba1121
+DIST proton-mail-bridge-3.3.2.tar.gz 4481491 BLAKE2B e00cf4268dcebc7f4eeab5a0738c04e1a809a5633b4d97637ea74aa4ac3eb68dd343b45fef5fca602c4c89faa2d1e05f1c605d9b56ee83d669b07b815f8ae92b SHA512 1b49355f8e816b6a00bf7fad91d0f696efb5ee1f5ea311fd4b92549f715185ea280ac874a759be5d3f8c7ff2309b8f0c3bb37c8502963059b26f4630bc9339f0
diff --git a/mail-mta/proton-mail-bridge/files/proton-mail-bridge-3.3.2-telemetry_default.patch b/mail-mta/proton-mail-bridge/files/proton-mail-bridge-3.3.2-telemetry_default.patch
new file mode 100644
index 000000000000..3c8df6c2ef9d
--- /dev/null
+++ b/mail-mta/proton-mail-bridge/files/proton-mail-bridge-3.3.2-telemetry_default.patch
@@ -0,0 +1,14 @@
+Such things really should be opt-in rather than opt-out, and doubly so given
+Gentoo does not package the bridge GUI yet.
+
+--- a/internal/vault/types_settings.go
++++ b/internal/vault/types_settings.go
+@@ -96,7 +96,7 @@
+ ShowAllMail: true,
+ Autostart: true,
+ AutoUpdate: true,
+- TelemetryDisabled: false,
++ TelemetryDisabled: true,
+
+ LastVersion: "0.0.0",
+ FirstStart: true,
diff --git a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.3.2.ebuild b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.3.2.ebuild
new file mode 100644
index 000000000000..a73779dc7b74
--- /dev/null
+++ b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.3.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd xdg-utils
+
+MY_PN="${PN/-mail/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Serves ProtonMail to IMAP/SMTP clients"
+HOMEPAGE="https://proton.me/mail/bridge https://github.com/ProtonMail/proton-bridge/"
+SRC_URI="https://github.com/ProtonMail/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+# FIXME: default telemetry to off!
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-3+ ISC LGPL-3+ MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gui"
+
+# Quite a few tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="app-crypt/libsecret"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.2-telemetry_default.patch
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ xdg_environment_reset
+ default
+}
+
+src_compile() {
+ if use gui; then
+ eerror "Since version 3.0.0, GUI support in ${PN} requires Qt6 and is therefore currently not available"
+ die "USE=gui requires Qt6"
+ else
+ emake build-nogui
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe bridge ${PN}
+
+ systemd_newuserunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use gui && xdg_icon_cache_update
+
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 3.2.0; then
+ ewarn "Please note that since version 3.2.0, ${PN} can share usage statistics with upstream."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://proton.me/support/share-usage-statistics"
+ ewarn
+ ewarn "Gentoo ebuilds change the default value of the 'send telemetry' setting to disabled."
+ ewarn
+ break
+ fi
+ done
+ fi
+}
+
+pkg_postrm() {
+ use gui && xdg_icon_cache_update
+}