summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-21 16:17:20 +0000
committerSam James <sam@gentoo.org>2023-12-22 06:42:35 +0000
commit24e30e2c9eabf3e6bd90c6812d30e22b42eff994 (patch)
treec9c8a1ffc09e0a621b58389fb99d6f4712a15091 /mate-base/libmatekbd/libmatekbd-1.26.1.ebuild
parentmate-base/caja: ebuild clean up (diff)
downloadgentoo-24e30e2c9eabf3e6bd90c6812d30e22b42eff994.tar.gz
gentoo-24e30e2c9eabf3e6bd90c6812d30e22b42eff994.tar.bz2
gentoo-24e30e2c9eabf3e6bd90c6812d30e22b42eff994.zip
mate-base/libmatekbd: add 1.26.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base/libmatekbd/libmatekbd-1.26.1.ebuild')
-rw-r--r--mate-base/libmatekbd/libmatekbd-1.26.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/mate-base/libmatekbd/libmatekbd-1.26.1.ebuild b/mate-base/libmatekbd/libmatekbd-1.26.1.ebuild
new file mode 100644
index 000000000000..ac8295234767
--- /dev/null
+++ b/mate-base/libmatekbd/libmatekbd-1.26.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE keyboard configuration library"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +introspection test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.24:2
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.2:0[introspection?]
+ x11-libs/pango
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_with X x) \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}