summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-09-03 16:23:26 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-09-25 16:31:54 -0400
commit8a198608e8af06ec731ac68dc776d4ebc555a671 (patch)
tree0cbd056b8b8438c4bcf8d7d1cd48ee2cafc41b08 /mate-base/mate-common/mate-common-1.24.2.ebuild
parentsys-fs/zfs: add exports.d patch (diff)
downloadgentoo-8a198608e8af06ec731ac68dc776d4ebc555a671.tar.gz
gentoo-8a198608e8af06ec731ac68dc776d4ebc555a671.tar.bz2
gentoo-8a198608e8af06ec731ac68dc776d4ebc555a671.zip
mate-base/mate-common: Bump to 1.24.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-base/mate-common/mate-common-1.24.2.ebuild')
-rw-r--r--mate-base/mate-common/mate-common-1.24.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/mate-base/mate-common/mate-common-1.24.2.ebuild b/mate-base/mate-common/mate-common-1.24.2.ebuild
new file mode 100644
index 000000000000..6c83b6fdcda7
--- /dev/null
+++ b/mate-base/mate-common/mate-common-1.24.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate-desktop.org
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Common files for development of MATE packages"
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+}
+
+src_install() {
+ mv doc-build/README README.doc-build \
+ || die "Failed to rename doc-build/README."
+
+ default
+
+ dodoc doc/usage.txt
+}