summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-22 09:16:41 +0000
committerSam James <sam@gentoo.org>2024-01-01 20:34:22 +0000
commit2510dd9a715d53dfd0500fad29567c8d2fe6694f (patch)
tree91a35498c4e282d8fe5101a2e4eadcdf2c59afb0 /mate-base
parentgui-wm/sway: sync live (diff)
downloadgentoo-2510dd9a715d53dfd0500fad29567c8d2fe6694f.tar.gz
gentoo-2510dd9a715d53dfd0500fad29567c8d2fe6694f.tar.bz2
gentoo-2510dd9a715d53dfd0500fad29567c8d2fe6694f.zip
mate-base/mate: +theme depends on x11-themes/mate-themes
As per bug, it is reasonable to assume that +themes would pull x11-themes/mate-themes in the meta package. Closes: https://bugs.gentoo.org/890959 Signed-off-by: Ian Jordan <immoloism@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34413 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate/mate-1.26.0-r1.ebuild83
-rw-r--r--mate-base/mate/mate-1.27.0-r1.ebuild85
2 files changed, 168 insertions, 0 deletions
diff --git a/mate-base/mate/mate-1.26.0-r1.ebuild b/mate-base/mate/mate-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..6d46f5c6b7a6
--- /dev/null
+++ b/mate-base/mate/mate-1.26.0-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_THEMES_V=3
+MATE_BRANCH="$(ver_cut 1-2)"
+MINOR=$(($(ver_cut 2) % 2))
+
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
+fi
+
+DESCRIPTION="Meta ebuild for MATE, a traditional desktop environment"
+HOMEPAGE="https://mate-desktop.org"
+
+LICENSE="metapackage"
+
+SLOT="0"
+IUSE="+base bluetooth help +notification +themes +extras"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ =mate-base/mate-desktop-${MATE_BRANCH}*
+ =mate-base/mate-menus-${MATE_BRANCH}*
+ =mate-base/mate-panel-${MATE_BRANCH}*
+ =mate-base/mate-session-manager-${MATE_BRANCH}*
+ =mate-base/mate-settings-daemon-${MATE_BRANCH}*
+ =x11-wm/marco-${MATE_BRANCH}*
+ base? (
+ =mate-base/caja-${MATE_BRANCH}*
+ =mate-base/mate-applets-meta-${MATE_BRANCH}*
+ =mate-base/mate-control-center-${MATE_BRANCH}*
+ =mate-extra/mate-media-${MATE_BRANCH}*
+ =x11-misc/mozo-${MATE_BRANCH}*
+ =x11-terms/mate-terminal-${MATE_BRANCH}*
+ )
+ bluetooth? ( net-wireless/blueman )
+ themes? (
+ =x11-themes/mate-backgrounds-${MATE_BRANCH}*
+ =x11-themes/mate-icon-theme-${MATE_BRANCH}*
+ =x11-themes/mate-themes-${MATE_THEMES_V}*
+ )
+ extras? (
+ =app-arch/engrampa-${MATE_BRANCH}*
+ =app-editors/pluma-${MATE_BRANCH}*
+ =app-text/atril-${MATE_BRANCH}*
+ =mate-extra/caja-extensions-${MATE_BRANCH}*
+ =mate-extra/mate-calc-${MATE_BRANCH}*
+ =mate-extra/mate-netbook-${MATE_BRANCH}*
+ =mate-extra/mate-power-manager-${MATE_BRANCH}*
+ =mate-extra/mate-screensaver-${MATE_BRANCH}*
+ =mate-extra/mate-system-monitor-${MATE_BRANCH}*
+ =mate-extra/mate-utils-${MATE_BRANCH}*
+ =media-gfx/eom-${MATE_BRANCH}*
+ )
+ help? (
+ gnome-extra/yelp
+ =mate-extra/mate-user-guide-${MATE_BRANCH}*
+ )
+"
+
+PDEPEND="
+ notification? ( =x11-misc/mate-notification-daemon-${MATE_BRANCH}* )
+ virtual/notification-daemon:0"
+
+pkg_postinst() {
+ elog "Please report all bugs to https:/bugs.gentoo.org"
+ elog ""
+ elog "For installation, usage and troubleshooting details regarding MATE;"
+ elog "read more about it at Gentoo Wiki: https://wiki.gentoo.org/wiki/MATE"
+ elog ""
+ if ! has_version x11-misc/mate-notification-daemon; then
+ elog "If you experience any issues with notifications, please try using"
+ elog "x11-misc/mate-notification-daemon instead your currently installed daemon"
+ elog ""
+ fi
+ elog "Some packages that are not included in this meta-package but may be of interest:"
+ elog " mate-extra/caja-dropbox"
+ elog " mate-extra/mate-user-share"
+ elog " mate-extra/caja-admin"
+}
diff --git a/mate-base/mate/mate-1.27.0-r1.ebuild b/mate-base/mate/mate-1.27.0-r1.ebuild
new file mode 100644
index 000000000000..bbd8f50e50b1
--- /dev/null
+++ b/mate-base/mate/mate-1.27.0-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_THEMES_V=3
+MATE_BRANCH="$(ver_cut 1-2)"
+MINOR=$(($(ver_cut 2) % 2))
+
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+SRC_URI=""
+DESCRIPTION="Meta ebuild for MATE, a traditional desktop environment"
+HOMEPAGE="https://mate-desktop.org"
+
+LICENSE="metapackage"
+
+SLOT="0"
+IUSE="+base bluetooth help +notification +themes +extras"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ =mate-base/mate-desktop-${MATE_BRANCH}*
+ =mate-base/mate-menus-${MATE_BRANCH}*
+ =mate-base/mate-panel-${MATE_BRANCH}*
+ =mate-base/mate-session-manager-${MATE_BRANCH}*
+ =mate-base/mate-settings-daemon-${MATE_BRANCH}*
+ =x11-wm/marco-${MATE_BRANCH}*
+ base? (
+ =mate-base/caja-${MATE_BRANCH}*
+ =mate-base/mate-applets-meta-${MATE_BRANCH}*
+ =mate-base/mate-control-center-${MATE_BRANCH}*
+ =mate-extra/mate-media-${MATE_BRANCH}*
+ =x11-misc/mozo-${MATE_BRANCH}*
+ =x11-terms/mate-terminal-${MATE_BRANCH}*
+ )
+ bluetooth? ( net-wireless/blueman )
+ themes? (
+ =x11-themes/mate-backgrounds-${MATE_BRANCH}*
+ =x11-themes/mate-icon-theme-${MATE_BRANCH}*
+ =x11-themes/mate-themes-${MATE_THEMES_V}*
+ )
+ extras? (
+ =app-arch/engrampa-${MATE_BRANCH}*
+ =app-editors/pluma-${MATE_BRANCH}*
+ =app-text/atril-${MATE_BRANCH}*
+ =mate-extra/caja-extensions-${MATE_BRANCH}*
+ =mate-extra/mate-calc-${MATE_BRANCH}*
+ =mate-extra/mate-netbook-${MATE_BRANCH}*
+ =mate-extra/mate-power-manager-${MATE_BRANCH}*
+ =mate-extra/mate-screensaver-${MATE_BRANCH}*
+ =mate-extra/mate-system-monitor-${MATE_BRANCH}*
+ =mate-extra/mate-utils-${MATE_BRANCH}*
+ =media-gfx/eom-${MATE_BRANCH}*
+ )
+ help? (
+ gnome-extra/yelp
+ =mate-extra/mate-user-guide-${MATE_BRANCH}*
+ )
+"
+
+PDEPEND="
+ notification? ( =x11-misc/mate-notification-daemon-${MATE_BRANCH}* )
+ virtual/notification-daemon:0"
+
+pkg_postinst() {
+ elog "1.27.x is a development release, if a stable desktop experince is required then use 1.26."
+ elog "Please report all issues to https:/bugs.gentoo.org"
+ elog ""
+ elog "For installation, usage and troubleshooting details regarding MATE;"
+ elog "read more about it at Gentoo Wiki: https://wiki.gentoo.org/wiki/MATE"
+ elog ""
+ if ! has_version x11-misc/mate-notification-daemon; then
+ elog "If you experience any issues with notifications, please try using"
+ elog "x11-misc/mate-notification-daemon instead your currently installed daemon"
+ elog ""
+ fi
+ elog "Some packages that are not included in this meta-package but may be of interest:"
+ elog " mate-extra/caja-dropbox"
+ elog " mate-extra/mate-user-share"
+ elog " mate-extra/caja-admin"
+}