summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-16 16:06:25 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-06-04 17:16:52 +0200
commitc8620769c8840e0fcd7f79539bb381ba17bda2bb (patch)
treead8bcdeb64c2cffa3943e3e79b43cc0802677765 /mate-extra/mate-user-share/mate-user-share-1.18.0.ebuild
parentx11-terms/mate-terminal: Version bump to 1.18.1 (diff)
downloadgentoo-c8620769c8840e0fcd7f79539bb381ba17bda2bb.tar.gz
gentoo-c8620769c8840e0fcd7f79539bb381ba17bda2bb.tar.bz2
gentoo-c8620769c8840e0fcd7f79539bb381ba17bda2bb.zip
mate-extra/mate-user-share: Version bump to 1.18.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'mate-extra/mate-user-share/mate-user-share-1.18.0.ebuild')
-rw-r--r--mate-extra/mate-user-share/mate-user-share-1.18.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/mate-extra/mate-user-share/mate-user-share-1.18.0.ebuild b/mate-extra/mate-user-share/mate-user-share-1.18.0.ebuild
new file mode 100644
index 000000000000..5fe69b733432
--- /dev/null
+++ b/mate-extra/mate-user-share/mate-user-share-1.18.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate multilib
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Personal file sharing for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.70:0
+ >=dev-libs/glib-2.15.2:2
+ >=mate-base/caja-1.17.1
+ media-libs/libcanberra:0[gtk3]
+ >=sys-apps/dbus-1.1.1:0
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-3.14:3
+ x11-libs/libX11:0
+ x11-libs/pango:0
+ >=x11-libs/libnotify-0.7:0
+ virtual/libintl:0"
+
+RDEPEND="${COMMON_DEPEND}
+ >=www-apache/mod_dnssd-0.6:0
+ >=www-servers/apache-2.2:2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile]"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.35:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --with-httpd=apache2 \
+ --with-modules-path=/usr/$(get_libdir)/apache2/modules/ \
+ --disable-bluetooth \
+ $(use_with X x)
+}