summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-24 21:19:36 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:48:50 -0400
commit73900222208ea5666047ace301480ad4890cad0c (patch)
tree148569d79b8e864656f6b51b0a4c4f067b53f2eb /mate-extra/mate-user-share/mate-user-share-1.24.0.ebuild
parentx11-terms/mate-terminal: Fix LICENSE (diff)
downloadgentoo-73900222208ea5666047ace301480ad4890cad0c.tar.gz
gentoo-73900222208ea5666047ace301480ad4890cad0c.tar.bz2
gentoo-73900222208ea5666047ace301480ad4890cad0c.zip
mate-extra/mate-user-share: Bump to 1.24.0
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-extra/mate-user-share/mate-user-share-1.24.0.ebuild')
-rw-r--r--mate-extra/mate-user-share/mate-user-share-1.24.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/mate-extra/mate-user-share/mate-user-share-1.24.0.ebuild b/mate-extra/mate-user-share/mate-user-share-1.24.0.ebuild
new file mode 100644
index 000000000000..df282eff4b2f
--- /dev/null
+++ b/mate-extra/mate-user-share/mate-user-share-1.24.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Personal file sharing for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.70
+ >=dev-libs/glib-2.50:2
+ >=mate-base/caja-1.17.1
+ media-libs/libcanberra[gtk3]
+ >=sys-apps/dbus-1.1.1
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/pango
+ >=x11-libs/libnotify-0.7
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=www-apache/mod_dnssd-0.6
+ >=www-servers/apache-2.2:2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile]
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8:*
+ virtual/pkgconfig:*
+"
+
+src_configure() {
+ mate_src_configure \
+ --with-httpd=apache2 \
+ --with-modules-path=/usr/$(get_libdir)/apache2/modules/ \
+ --disable-bluetooth \
+ $(use_with X x)
+}