summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 10:22:17 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-30 18:41:48 -0400
commit3ae624a99d166b9b200b8c8a83272f333a1994ca (patch)
tree50d2bc1270f21cbd8fd11f2a6ef415943568667f /mate-extra
parentmate-extra/mate-power-manager: Bump to 1.24.2 (diff)
downloadgentoo-3ae624a99d166b9b200b8c8a83272f333a1994ca.tar.gz
gentoo-3ae624a99d166b9b200b8c8a83272f333a1994ca.tar.bz2
gentoo-3ae624a99d166b9b200b8c8a83272f333a1994ca.zip
mate-extra/mate-system-monitor: Bump to 1.24.2
Bug: https://bugs.gentoo.org/778857 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index 4d5250b09c6c..c64600cc4f60 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1 +1,2 @@
DIST mate-system-monitor-1.24.1.tar.xz 2420872 BLAKE2B 27572e523ea358a5315b6a42dc29e6c48c4341d4cdf34edb039429a455e1d924417aeb8602e0a71d4e71b04988ccadc82bc84794411644eefb1bd976e5744e90 SHA512 5fdf8ff52584f91fbe12270af2b5bb1c81d5c4d6001bdaad9c6001dbb6e6020254048e32aa6549eb686ad17998c1aa220e5463057502ba514c4a5b82953f2b05
+DIST mate-system-monitor-1.24.2.tar.xz 2429196 BLAKE2B 03d0555d74ba4ba9a80727fa383ad02515a46f61fd1df3487b7acabef4b0561e03d86082c9c161a533716416bab73fad5bd826329c69d1826eeb7dd73a1b4e41 SHA512 4fd0f1a3dc5611d66b2e1ca35171f2056994332f87d895321c384a696afa359a2b78d2b0c2d698923039549f886976f04b1a8c92c928dfe9e2a1a159540a1895
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.2.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.2.ebuild
new file mode 100644
index 000000000000..1c7ebffed1d0
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind systemd"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.56:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=()
+
+ if use elogind || use systemd; then
+ myconf+=( --enable-systemd )
+ if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
+ myconf+=(
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags 'libelogind')"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs 'libelogind')"
+ )
+ fi
+ else
+ myconf+=( --disable-systemd )
+ fi
+
+ mate_src_configure "${myconf[@]}"
+}