summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaud CANALE <thican@thican.net>2024-01-22 01:06:40 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-08 11:17:20 +0200
commit69626a08f52afbb8cc58291990b063766fce7f37 (patch)
treeb3260e04af74babf409b2ae814349ae7da662a00 /mate-extra
parentsys-fs/mount-zip: add 1.0.12 (diff)
downloadgentoo-69626a08f52afbb8cc58291990b063766fce7f37.tar.gz
gentoo-69626a08f52afbb8cc58291990b063766fce7f37.tar.bz2
gentoo-69626a08f52afbb8cc58291990b063766fce7f37.zip
mate-extra/mate-polkit: add 1.26.1
Closes: https://bugs.gentoo.org/922653 Signed-off-by: Thibaud CANALE <thican@thican.net> Closes: https://github.com/gentoo/gentoo/pull/35226 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.26.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index f86a47ec81d7..09bc7e1d7027 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1,2 +1,3 @@
DIST mate-polkit-1.26.0.tar.xz 335768 BLAKE2B 15b1fd38efcb157802ff96f09879a8790d6a8356d6fe75f833bcd4b9f088e30b019a7e0739d48000aed4a7d9b5634727c2176ce7b725d82431118c7da4e04f04 SHA512 393a8a0a9567ec75762dcd1e776a1544756f4b9b88b8bbb4f6d1ed87dcc25c30025e27d6f4e18c04c79f5f02152490f577fb89c758ce042dc466a387d9202e0f
+DIST mate-polkit-1.26.1.tar.xz 344216 BLAKE2B 4ebb173bfc94f87199aa53cc9cede9a454969801b57a6702e85bf695ad23c7b2b29c62e1428d3b28afb32d96b98dfa6252142b0c23ad8f78fb0807f3cca866a4 SHA512 0c8e881991d90af3121212c2dbb931bcea9ab9b9d22e0664d866b8a2bc95f2427bba09635be35f1a01404efd83b567d8a3d947cca84562463591a7821fb85678
DIST mate-polkit-1.27.1.tar.xz 345096 BLAKE2B ffdf98fbfc8d840a441b33ef7db3e09ac9a651fa9af9d68df52b939abd5322f3fdba352114fbfc442ebbb794c50a305687f171ad38fe3b79182749cde7e6f0a9 SHA512 5dc91c02e8538c214b72ac799ac7724327e8c950837213a41f91ecdc25834b0ef059143f173f570b8ac1195a76b073c54a189e3067a91b3ca8382edaf98d740c
diff --git a/mate-extra/mate-polkit/mate-polkit-1.26.1.ebuild b/mate-extra/mate-polkit/mate-polkit-1.26.1.ebuild
new file mode 100644
index 000000000000..cbb5703f56fd
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.26.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+if [[ "${PV}" != *9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND="
+ virtual/libintl:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22.0:3
+ appindicator? ( dev-libs/libayatana-appindicator )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ >=dev-libs/glib-2.50:2
+ >=sys-auth/polkit-0.102[daemon]
+ accountsservice? ( sys-apps/accountsservice )
+"
+
+BDEPEND="
+ ${COMMON_DEPEND}
+ dev-build/gtk-doc-am
+ >=dev-build/libtool-2.2.6
+ dev-util/gtk-doc
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://github.com/mate-desktop/mate-polkit/commit/65a6c367e28e338dc74931dece1af9e53338276f
+ "${FILESDIR}/${PN}-1.26.0-ayatana.patch"
+)
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}