summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-03-31 09:39:19 +0200
committerHans de Graaff <graaff@gentoo.org>2018-03-31 09:39:51 +0200
commit1bc69a5e200f0112acf4d9f4ffd604c6813ce680 (patch)
tree67868372db82cfcb8d5965797fbbcc4db1e7254e /media-fonts/fira-code/fira-code-1.205.ebuild
parentx11-proto/xproto-7.0.31-r1: hppa stable, bug 651286 (diff)
downloadgentoo-1bc69a5e200f0112acf4d9f4ffd604c6813ce680.tar.gz
gentoo-1bc69a5e200f0112acf4d9f4ffd604c6813ce680.tar.bz2
gentoo-1bc69a5e200f0112acf4d9f4ffd604c6813ce680.zip
media-fonts/fira-code: initial import of 1.205
This ebuild also includes an upstream Symbol version of the glyphs that can be used by editors that don't support ligatures, e.g. Emacs. Closes: https://bugs.gentoo.org/569786 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-fonts/fira-code/fira-code-1.205.ebuild')
-rw-r--r--media-fonts/fira-code/fira-code-1.205.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-fonts/fira-code/fira-code-1.205.ebuild b/media-fonts/fira-code/fira-code-1.205.ebuild
new file mode 100644
index 000000000000..5c694368809a
--- /dev/null
+++ b/media-fonts/fira-code/fira-code-1.205.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit font
+
+DESCRIPTION="Monospaced font with programming ligatures"
+HOMEPAGE="https://github.com/tonsky/FiraCode"
+SRC_URI="https://github.com/tonsky/FiraCode/archive/${PV}.tar.gz -> ${P}.tar.gz https://github.com/tonsky/FiraCode/files/412440/FiraCode-Regular-Symbol.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/FiraCode-${PV}"
+FONT_S="${S}/distr/otf"
+FONT_SUFFIX="otf"
+
+DOCS="README.md"
+
+src_prepare() {
+ mv "${WORKDIR}"/*.otf "${FONT_S}" || die
+
+ default
+}