summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/intlfonts/intlfonts-1.2.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/intlfonts/intlfonts-1.2.1.ebuild')
-rw-r--r--media-fonts/intlfonts/intlfonts-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-fonts/intlfonts/intlfonts-1.2.1.ebuild b/media-fonts/intlfonts/intlfonts-1.2.1.ebuild
new file mode 100644
index 000000000000..25225cfff4ce
--- /dev/null
+++ b/media-fonts/intlfonts/intlfonts-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit font
+
+IUSE="bdf"
+
+DESCRIPTION="International X11 fixed fonts"
+HOMEPAGE="http://www.gnu.org/directory/intlfonts.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+
+DEPEND="x11-apps/bdftopcf
+ x11-apps/mkfontdir"
+RDEPEND=""
+
+src_compile() {
+ econf --with-fontdir=/usr/share/fonts/${PN}
+}
+
+src_install() {
+ emake install fontdir="${D}/usr/share/fonts/${PN}" || die
+ find "${D}/usr/share/fonts/${PN}" -name '*.pcf' | xargs gzip -9
+ use bdf || rm -rf "${D}/usr/share/fonts/${PN}/bdf"
+ dodoc ChangeLog NEWS README
+ dodoc Emacs.ap
+ font_xfont_config
+}