summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-02-23 08:51:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-02-23 08:52:12 +0200
commitf9e4410876dd83eb2dbfd450ee10b7d7541fb389 (patch)
tree310aac38d34bd3e6af06678acfa6954c6003818e /media-fonts/office-code-pro/office-code-pro-1.004.ebuild
parentdev-ruby/polyglot: add ruby27 (diff)
downloadgentoo-f9e4410876dd83eb2dbfd450ee10b7d7541fb389.tar.gz
gentoo-f9e4410876dd83eb2dbfd450ee10b7d7541fb389.tar.bz2
gentoo-f9e4410876dd83eb2dbfd450ee10b7d7541fb389.zip
media-fonts/office-code-pro: new font package
- Customized version of Source Code Pro. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-fonts/office-code-pro/office-code-pro-1.004.ebuild')
-rw-r--r--media-fonts/office-code-pro/office-code-pro-1.004.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-fonts/office-code-pro/office-code-pro-1.004.ebuild b/media-fonts/office-code-pro/office-code-pro-1.004.ebuild
new file mode 100644
index 000000000000..23be1877518b
--- /dev/null
+++ b/media-fonts/office-code-pro/office-code-pro-1.004.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font
+
+DESCRIPTION="Customized version of Source Code Pro"
+HOMEPAGE="https://github.com/nathco/Office-Code-Pro"
+SRC_URI="https://github.com/nathco/Office-Code-Pro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/Office-Code-Pro-${PV}"
+
+FONT_S="${S}"
+FONT_SUFFIX="otf"
+
+src_prepare() {
+ default
+
+ mv Fonts/*/OTF/*.otf . || die "Failed to move .otf files"
+}