summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-04-19 21:19:50 +0200
committerJohannes Huber <johu@gentoo.org>2018-04-19 21:22:05 +0200
commit2ac6ff64339e9fbfb9b5b21aa1a4061003093461 (patch)
tree339f73c6baec31df63be34ef9bc2efa363ec94c2 /media-fonts/ricty/ricty-3.2.0-r2.ebuild
parentdev-util/scons: improve PATH fix for Prefix (diff)
downloadgentoo-2ac6ff64339e9fbfb9b5b21aa1a4061003093461.tar.gz
gentoo-2ac6ff64339e9fbfb9b5b21aa1a4061003093461.tar.bz2
gentoo-2ac6ff64339e9fbfb9b5b21aa1a4061003093461.zip
media-fonts/ricty: Revision bump 3.2.0-r2
EAPI 6 Package-Manager: Portage-2.3.30, Repoman-2.3.9
Diffstat (limited to 'media-fonts/ricty/ricty-3.2.0-r2.ebuild')
-rw-r--r--media-fonts/ricty/ricty-3.2.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-fonts/ricty/ricty-3.2.0-r2.ebuild b/media-fonts/ricty/ricty-3.2.0-r2.ebuild
new file mode 100644
index 000000000000..0c8d7ee3e056
--- /dev/null
+++ b/media-fonts/ricty/ricty-3.2.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit font
+
+MY_PN="Ricty"
+DESCRIPTION="A beautiful sans-serif monotype Japanese font designed for code listings"
+HOMEPAGE="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty.html"
+#SRC_URI="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty/${MY_PN}-${PV}.tar.gz"
+SRC_URI="https://github.com/yascentur/${MY_PN}/tarball/${PV} -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-fonts/inconsolata
+ >=media-fonts/mix-mplus-ipa-20111002
+ media-gfx/fontforge"
+RDEPEND=""
+
+#S="${WORKDIR}/yascentur-${MY_PN}-*"
+S="${WORKDIR}/yascentur-${MY_PN}-b9d8b9c"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+
+# Only installs fonts.
+RESTRICT="strip binchecks"
+
+src_compile() {
+ sh ricty_generator.sh \
+ "${EPREFIX}/usr/share/fonts/inconsolata/Inconsolata-Regular.ttf" \
+ "${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-regular.ttf" \
+ "${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-bold.ttf" || die
+}