summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-16 15:51:12 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-16 15:52:01 +0200
commitc9c604a9ede9659a8286ec23eca393496e8e35e2 (patch)
tree6a55212110567f1bacdb0950066a1452886fe7d2 /media-fonts/source-pro/source-pro-20160608.ebuild
parentdev-ruby/tilt: Remove old (diff)
downloadgentoo-c9c604a9ede9659a8286ec23eca393496e8e35e2.tar.gz
gentoo-c9c604a9ede9659a8286ec23eca393496e8e35e2.tar.bz2
gentoo-c9c604a9ede9659a8286ec23eca393496e8e35e2.zip
media-fonts/source-pro: Bump to version 20160608 (bug #560996).
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-fonts/source-pro/source-pro-20160608.ebuild')
-rw-r--r--media-fonts/source-pro/source-pro-20160608.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-fonts/source-pro/source-pro-20160608.ebuild b/media-fonts/source-pro/source-pro-20160608.ebuild
new file mode 100644
index 000000000000..5c6c135acbab
--- /dev/null
+++ b/media-fonts/source-pro/source-pro-20160608.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit font
+
+SANSV="2.020R-ro/1.075R-it"
+SERIFV="1.017R"
+CODEV="2.030R-ro/1.050R-it"
+
+DESCRIPTION="Adobe's open source typeface family designed for UI environments"
+HOMEPAGE="http://adobe-fonts.github.io/source-sans-pro
+ http://adobe-fonts.github.io/source-serif-pro
+ http://adobe-fonts.github.io/source-code-pro"
+SRC_URI="https://github.com/adobe-fonts/source-sans-pro/archive/${SANSV}.tar.gz -> source-sans-pro-${PV}.tar.gz
+ https://github.com/adobe-fonts/source-serif-pro/archive/${SERIFV}.tar.gz -> source-serif-pro-${PV}.tar.gz
+ https://github.com/adobe-fonts/source-code-pro/archive/${CODEV}.tar.gz -> source-code-pro-${PV}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x64-macos"
+IUSE="cjk"
+
+RDEPEND="media-libs/fontconfig
+ cjk? ( media-fonts/source-han-sans )"
+
+S=${WORKDIR}
+FONT_S="${S}"
+FONT_SUFFIX="otf"
+FONT_CONF=( "${FILESDIR}"/63-${PN}.conf )
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ mv source-*/OTF/*.otf . || die
+}
+
+src_install() {
+ font_src_install
+ for d in source-sans-pro-${SANSV/\//-} source-serif-pro-${SERIFV} source-code-pro-${CODEV/\//-}; do
+ newdoc ${d}/README.md README-${d}.md
+ done
+}