summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild')
-rw-r--r--media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
new file mode 100644
index 000000000000..ecbe65795e11
--- /dev/null
+++ b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+S="${WORKDIR}"
+inherit eutils font toolchain-funcs
+
+MY_P="kcfonts-${PV}"
+DESCRIPTION="Kuo Chauo Chinese Fonts collection in BIG5 encoding"
+SRC_URI="ftp://freebsd.sinica.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ ftp://wm28.csie.ncu.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}-freebsd-aa_ad.patch.gz"
+HOMEPAGE="http://freebsd.sinica.edu.tw/"
+# no real homepage exists, but this was written by Taiwanese FreeBSD devs
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+DEPEND="x11-apps/bdftopcf"
+RDEPEND=""
+
+FONT_SUFFIX="pcf.gz"
+DOCS="00README Xdefaults.*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}/${MY_P}-freebsd-aa_ad.patch"
+ epatch "${FILESDIR}/${MY_P}-code-fixups.patch"
+ epatch "${FILESDIR}/${MY_P}-parallel-make.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}