summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 11:25:33 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 11:33:04 +0100
commitddbf062159321c203f918f3795c076521073576f (patch)
tree707ffd38be1f5158b0c6ec9e00b5d5d921dd2e66 /media-gfx/ansilove/ansilove-9999.ebuild
parentdev-libs/libansilove: new package; add version 1.2.8 and live (diff)
downloadgentoo-ddbf062159321c203f918f3795c076521073576f.tar.gz
gentoo-ddbf062159321c203f918f3795c076521073576f.tar.bz2
gentoo-ddbf062159321c203f918f3795c076521073576f.zip
media-gfx/ansilove: new package; add version 4.1.5 and live
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'media-gfx/ansilove/ansilove-9999.ebuild')
-rw-r--r--media-gfx/ansilove/ansilove-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/ansilove/ansilove-9999.ebuild b/media-gfx/ansilove/ansilove-9999.ebuild
new file mode 100644
index 000000000000..747102f7845f
--- /dev/null
+++ b/media-gfx/ansilove/ansilove-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
+HOMEPAGE="https://github.com/ansilove/ansilove/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+else
+ SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="dev-libs/libansilove"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_SECCOMP=NO
+ )
+ cmake_src_configure
+}