summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-02-05 15:04:00 +0100
committerStephan Hartmann <sultan@gentoo.org>2022-02-05 15:04:18 +0100
commit45fd0cde71ca2ae0e7e38ab67400d84b86b593d7 (patch)
tree68321a834f9eb05ca53fe17980e677a1f9c086cd /media-gfx/apngasm
parentdev-libs/nss: add 3.75 (diff)
downloadgentoo-45fd0cde71ca2ae0e7e38ab67400d84b86b593d7.tar.gz
gentoo-45fd0cde71ca2ae0e7e38ab67400d84b86b593d7.tar.bz2
gentoo-45fd0cde71ca2ae0e7e38ab67400d84b86b593d7.zip
media-gfx/apngasm: fix parallel build
Closes: https://bugs.gentoo.org/830893 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'media-gfx/apngasm')
-rw-r--r--media-gfx/apngasm/files/apngasm-3.1.10-static.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-gfx/apngasm/files/apngasm-3.1.10-static.patch b/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
index a624d03278f3..fdc4f5ea41e8 100644
--- a/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
+++ b/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
@@ -1,3 +1,14 @@
+--- a/cli/CMakeLists.txt
++++ b/cli/CMakeLists.txt
+@@ -51,7 +51,7 @@ set_target_properties(apngasm-cli
+
+ # Link to built apngasm library
+ target_link_libraries(apngasm-cli
+- apngasm
++ apngasm-dynamic
+ ${Boost_LIBRARIES}
+ )
+
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -55,18 +55,6 @@ set_target_properties(${APNGASM_DYNAMIC_LIB_TARGET}