summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/aqsis/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/aqsis/files')
-rw-r--r--media-gfx/aqsis/files/aqsis-1.8.2-openexr-compat.patch15
-rw-r--r--media-gfx/aqsis/files/aqsis-1.8.2-unbundle-tinyxml.patch57
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/aqsis/files/aqsis-1.8.2-openexr-compat.patch b/media-gfx/aqsis/files/aqsis-1.8.2-openexr-compat.patch
new file mode 100644
index 000000000000..155c93ebb295
--- /dev/null
+++ b/media-gfx/aqsis/files/aqsis-1.8.2-openexr-compat.patch
@@ -0,0 +1,15 @@
+--- libs/tex/io/exrinputfile.h.orig 2012-08-24 16:26:50.000000000 +0400
++++ libs/tex/io/exrinputfile.h 2014-02-14 16:26:47.293497092 +0400
+@@ -48,10 +48,9 @@
+
+ #include <aqsis/tex/io/itexinputfile.h>
+
++#include <OpenEXR/ImfInputFile.h>
++
+ //------------------------------------------------------------------------------
+-namespace Imf {
+- class InputFile;
+-}
+
+ namespace Aqsis {
+
diff --git a/media-gfx/aqsis/files/aqsis-1.8.2-unbundle-tinyxml.patch b/media-gfx/aqsis/files/aqsis-1.8.2-unbundle-tinyxml.patch
new file mode 100644
index 000000000000..158c96aeabce
--- /dev/null
+++ b/media-gfx/aqsis/files/aqsis-1.8.2-unbundle-tinyxml.patch
@@ -0,0 +1,57 @@
+--- CMakeLists.txt.orig 2014-02-14 16:55:38.894647998 +0400
++++ CMakeLists.txt 2014-02-14 16:56:14.017651059 +0400
+@@ -134,15 +134,15 @@
+ endif()
+ endif()
+
+-## find tinyxml. If not found we use the version distributed with the aqsis
+-## source.
+-#if(AQSIS_USE_EXTERNAL_TINYXML)
+-# find_package(TinyXML)
+-# if(NOT TINYXML_FOUND)
+-# message("** Cannot find external tinyxml library - using version included with the aqsis source.")
+-# set(AQSIS_USE_EXTERNAL_TINYXML OFF)
+-# endif()
+-#endif()
++# find tinyxml. If not found we use the version distributed with the aqsis
++# source.
++if(AQSIS_USE_EXTERNAL_TINYXML)
++ find_package(TinyXML)
++ if(NOT AQSIS_TINYXML_FOUND)
++ message("** Cannot find external tinyxml library - using version included with the aqsis source.")
++ set(AQSIS_USE_EXTERNAL_TINYXML OFF)
++ endif()
++endif()
+
+
+ #-------------------------------------------------------------------------------
+@@ -274,7 +274,9 @@
+ )
+
+ # Thirdparty libs
+-declare_subproject(thirdparty/tinyxml)
++if(NOT AQSIS_USE_EXTERNAL_TINYXML)
++ declare_subproject(thirdparty/tinyxml)
++endif()
+ declare_subproject(thirdparty/partio)
+ declare_subproject(libs/pointrender)
+ if(AQSIS_USE_PDIFF)
+--- tools/piqsl/CMakeLists.txt.orig 2014-02-16 11:18:43.308699170 +0400
++++ tools/piqsl/CMakeLists.txt 2014-02-16 11:18:52.620699981 +0400
+@@ -5,8 +5,6 @@
+ message(FATAL_ERROR "Piqsl requires boost thread and Qt4 to build")
+ endif()
+
+-include_subproject(tinyxml)
+-
+ set(piqsl_hdrs
+ displayserverimage.h
+ image.h
+--- tools/displays/piqsl/CMakeLists.txt.orig 2014-02-16 11:21:25.820713332 +0400
++++ tools/displays/piqsl/CMakeLists.txt 2014-02-16 11:21:34.676714104 +0400
+@@ -1,5 +1,4 @@
+ include_subproject(dspyutil)
+-include_subproject(tinyxml)
+
+ aqsis_add_display(piqsl piqsldisplay.cpp ${dspyutil_srcs}
+ ${tinyxml_srcs} ${tinyxml_hdrs}