summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 16:11:02 +0300
committerAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 16:11:02 +0300
commit80e62b6c736134c9ad0cedf85c677feda3b98ad5 (patch)
tree3d61a18ef23467995327a71314534d72e428d37f /media-gfx/cura/cura-3.3.1.ebuild
parentmedia-gfx/fdm-materials: New package (diff)
downloadgentoo-80e62b6c736134c9ad0cedf85c677feda3b98ad5.tar.gz
gentoo-80e62b6c736134c9ad0cedf85c677feda3b98ad5.tar.bz2
gentoo-80e62b6c736134c9ad0cedf85c677feda3b98ad5.zip
media-gfx/cura: Version bump and clean up
Closes: https://bugs.gentoo.org/630620 Closes: https://bugs.gentoo.org/648130 Closes: https://github.com/gentoo/gentoo/pull/8258 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-gfx/cura/cura-3.3.1.ebuild')
-rw-r--r--media-gfx/cura/cura-3.3.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/cura/cura-3.3.1.ebuild b/media-gfx/cura/cura-3.3.1.ebuild
new file mode 100644
index 000000000000..c8501394398e
--- /dev/null
+++ b/media-gfx/cura/cura-3.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit cmake-utils fdo-mime gnome2-utils python-single-r1
+
+MY_PN=Cura
+
+DESCRIPTION="A 3D model slicing application for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/Cura"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+usb zeroconf"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/uranium[${PYTHON_USEDEP}]
+ media-gfx/curaengine
+ media-gfx/fdm-materials
+ dev-libs/libsavitar:=[python,${PYTHON_USEDEP}]
+ dev-libs/libcharon[${PYTHON_USEDEP}]
+ usb? ( dev-python/pyserial[${PYTHON_USEDEP}] )
+ zeroconf? ( dev-python/zeroconf[${PYTHON_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+PATCHES=( "${FILESDIR}/${PN}-3.3.0-fix-install-paths.patch" )
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon icons/*.png
+ python_optimize "${D}${get_libdir}"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}