summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-10-11 12:59:54 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-10-11 13:25:46 +0200
commit7bfa574a4f53a756da5564713ba85fd9ce5db6ad (patch)
tree3a8b14211c4ecd4a0b66fec4de492fd49a077379 /media-gfx/curaengine/curaengine-4.2.0.ebuild
parentmedia-gfx/cura: drop old (diff)
downloadgentoo-7bfa574a4f53a756da5564713ba85fd9ce5db6ad.tar.gz
gentoo-7bfa574a4f53a756da5564713ba85fd9ce5db6ad.tar.bz2
gentoo-7bfa574a4f53a756da5564713ba85fd9ce5db6ad.zip
media-gfx/curaengine: drop old
Signed-off-by: Dennis Lamm <expeditoneer@gentoo.org> Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'media-gfx/curaengine/curaengine-4.2.0.ebuild')
-rw-r--r--media-gfx/curaengine/curaengine-4.2.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-gfx/curaengine/curaengine-4.2.0.ebuild b/media-gfx/curaengine/curaengine-4.2.0.ebuild
deleted file mode 100644
index 812973727d59..000000000000
--- a/media-gfx/curaengine/curaengine-4.2.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake toolchain-funcs
-
-MY_PN="CuraEngine"
-
-DESCRIPTION="A 3D model slicing engine for 3D printing"
-HOMEPAGE="https://github.com/Ultimaker/CuraEngine"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="|| ( <sys-devel/gcc-9 <sys-devel/clang-8 )
- doc? ( app-doc/doxygen )"
-RDEPEND="${PYTHON_DEPS}
- ~dev-libs/libarcus-${PV}:*
- dev-libs/protobuf
- dev-libs/stb"
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-pkg_pretend() {
- if [[ $(tc-getCC) == clang ]] && [[ $(clang-major-version) -ge 8 ]]; then
- eerror "Compilation with sys-devel/clang-8 or newer is not supported"
- eerror "See https://github.com/Ultimaker/CuraEngine/issues/984 for more information"
- eerror ""
- die "Incompatible clang version found"
- elif [[ $(gcc-major-version) -ge 9 ]]; then
- eerror "Compilation with sys-devel/gcc-9 or newer is not supported"
- eerror "See https://github.com/Ultimaker/CuraEngine/issues/984 for more information"
- eerror ""
- die "Incompatible gcc version found"
- fi
-}
-
-src_configure() {
- local mycmakeargs=( "-DBUILD_TESTS=$(usex test ON OFF)" )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_build
- if use doc; then
- doxygen
- mv docs/html . || die
- find html -name '*.md5' -or -name '*.map' -delete || die
- DOCS+=( html )
- fi
-}