summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/fbida/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/fbida/files')
-rw-r--r--media-gfx/fbida/files/fbida-2.09-giflib.patch97
-rw-r--r--media-gfx/fbida/files/fbida-2.09-make.patch36
-rw-r--r--media-gfx/fbida/files/fbida-2.10-giflib-4.2.patch17
-rw-r--r--media-gfx/fbida/files/ida-desktop.patch17
4 files changed, 167 insertions, 0 deletions
diff --git a/media-gfx/fbida/files/fbida-2.09-giflib.patch b/media-gfx/fbida/files/fbida-2.09-giflib.patch
new file mode 100644
index 000000000000..50c005589974
--- /dev/null
+++ b/media-gfx/fbida/files/fbida-2.09-giflib.patch
@@ -0,0 +1,97 @@
+--- a/rd/read-gif.c
++++ b/rd/read-gif.c
+@@ -25,7 +25,13 @@
+ if (GIF_ERROR == DGifGetRecordType(h->gif,&RecordType)) {
+ if (debug)
+ fprintf(stderr,"gif: DGifGetRecordType failed\n");
+- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ GifErrorString(D_GIF_ERR_NOT_GIF_FILE);
++#elif (GIFLIB_MAJOR >= 4 && GIFLIB_MINOR >=2)
++ GifErrorString();
++#else
++ PrintGifError();
++#endif
+ return -1;
+ }
+ switch (RecordType) {
+@@ -42,7 +48,13 @@
+ if (rc == GIF_ERROR) {
+ if (debug)
+ fprintf(stderr,"gif: DGifGetExtension failed\n");
++#if GIFLIB_MAJOR >= 5
++ GifErrorString(D_GIF_ERR_NOT_GIF_FILE);
++#elif (GIFLIB_MAJOR >= 4 && GIFLIB_MINOR >=2)
++ GifErrorString();
++#else
+ PrintGifError();
++#endif
+ return -1;
+ }
+ if (debug) {
+@@ -93,12 +105,19 @@
+ struct gif_state *h;
+ GifRecordType RecordType;
+ int i, image = 0;
++#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
++ int ErrorCode;
++#endif
+
+ h = malloc(sizeof(*h));
+ memset(h,0,sizeof(*h));
+
+ h->infile = fp;
++#if GIFLIB_MAJOR >= 5
++ h->gif = DGifOpenFileHandle(fileno(fp), NULL);
++#else
+ h->gif = DGifOpenFileHandle(fileno(fp));
++#endif
+ h->row = malloc(h->gif->SWidth * sizeof(GifPixelType));
+
+ while (0 == image) {
+@@ -108,7 +127,15 @@
+ if (GIF_ERROR == DGifGetImageDesc(h->gif)) {
+ if (debug)
+ fprintf(stderr,"gif: DGifGetImageDesc failed\n");
++#if (GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1)
++ GifErrorString(D_GIF_ERR_NO_IMAG_DSCR);
++#elif GIFLIB_MAJOR >= 5
++ GifErrorString(NULL);
++#elif (GIFLIB_MAJOR >= 4 && GIFLIB_MINOR >=2)
++ GifErrorString();
++#else
+ PrintGifError();
++#endif
+ }
+ if (NULL == h->gif->SColorMap &&
+ NULL == h->gif->Image.ColorMap) {
+@@ -156,7 +183,11 @@
+ oops:
+ if (debug)
+ fprintf(stderr,"gif: fatal error, aborting\n");
++#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
++ DGifCloseFile(h->gif, &ErrorCode);
++#else
+ DGifCloseFile(h->gif);
++#endif
+ fclose(h->infile);
+ free(h->row);
+ free(h);
+@@ -193,10 +224,17 @@
+ gif_done(void *data)
+ {
+ struct gif_state *h = data;
++#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
++ int ErrorCode;
++#endif
+
+ if (debug)
+ fprintf(stderr,"gif: done, cleaning up\n");
++#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
++ DGifCloseFile(h->gif, &ErrorCode);
++#else
+ DGifCloseFile(h->gif);
++#endif
+ fclose(h->infile);
+ if (h->il)
+ free(h->il);
diff --git a/media-gfx/fbida/files/fbida-2.09-make.patch b/media-gfx/fbida/files/fbida-2.09-make.patch
new file mode 100644
index 000000000000..61c19a3cfc72
--- /dev/null
+++ b/media-gfx/fbida/files/fbida-2.09-make.patch
@@ -0,0 +1,36 @@
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -30,8 +30,8 @@
+
+ ac_jpeg_ver = $(shell \
+ $(call ac_init,for libjpeg version);\
+- $(call ac_s_cmd,echo -e '\#include <jpeglib.h>\nJPEG_LIB_VERSION' \
+- | cpp | tail -n 1);\
++ $(call ac_s_cmd,printf '\#include <jpeglib.h>\nJPEG_LIB_VERSION' \
++ | $(CPP) | tail -n 1);\
+ $(call ac_fini))
+
+ define make-config
+--- a/mk/Autoconf.mk
++++ b/mk/Autoconf.mk
+@@ -24,7 +24,7 @@ ifneq ($(verbose),no)
+ ac_fini = echo "... result is $${rc}" >&2; echo >&2; echo "$${rc}"
+ else
+ # normal
+- ac_init = echo -n "checking $(1) ... " >&2; rc=no
++ ac_init = printf '%s' "checking $(1) ... " >&2; rc=no
+ ac_b_cmd = $(1) >/dev/null 2>&1 && rc=yes
+ ac_s_cmd = rc=`$(1) 2>/dev/null`
+ ac_fini = echo "$${rc}" >&2; echo "$${rc}"
+@@ -162,7 +162,7 @@ config: Make.config
+ @true
+
+ Make.config: $(srcdir)/GNUmakefile
+- @echo -e "$(make-config-q)" > $@
++ @printf '%b' "$(make-config-q)" > $@
+ @echo
+ @echo "Make.config written, edit if needed"
+ @echo
+--
+1.7.5.3
+
diff --git a/media-gfx/fbida/files/fbida-2.10-giflib-4.2.patch b/media-gfx/fbida/files/fbida-2.10-giflib-4.2.patch
new file mode 100644
index 000000000000..1e21b8af2bd7
--- /dev/null
+++ b/media-gfx/fbida/files/fbida-2.10-giflib-4.2.patch
@@ -0,0 +1,17 @@
+--- a/rd/read-gif.c
++++ b/rd/read-gif.c
+@@ -14,6 +14,14 @@
+ }
+ #else
+ #define GIF5DATA(x)
++// v4.2 removed PrintGifError in favor of GifErrorString, but with a different
++// prototype than v5
++#if defined(GIFLIB_MAJOR) && defined(GIFLIB_MINOR) && (GIFLIB_MAJOR == 4) && (GIFLIB_MINOR == 2)
++static void PrintGifError()
++{
++ fprintf(stderr, "GIF library error: %s\n", GifErrorString());
++}
++#endif
+ #define PrintGifError(e) PrintGifError()
+ #define DGifOpenFileHandle(x,e) DGifOpenFileHandle(x)
+ #define DGifCloseFile(x,e) DGifCloseFile(x)
diff --git a/media-gfx/fbida/files/ida-desktop.patch b/media-gfx/fbida/files/ida-desktop.patch
new file mode 100644
index 000000000000..eaac0ed69558
--- /dev/null
+++ b/media-gfx/fbida/files/ida-desktop.patch
@@ -0,0 +1,17 @@
+--- a/desktop/ida.desktop
++++ b/desktop/ida.desktop
+@@ -1,9 +1,10 @@
+ [Desktop Entry]
+ Type=Application
+-Encoding=UTF-8
+ Name=ida
+ GenericName=Image Viewer
++Comment=Image Viewer
+ Exec=ida %F
+-Terminal=no
+-Categories=Motif;Graphics;Viewer
+-MimeType=image/jpeg;image/tiff;image/png
++Terminal=false
++Categories=Motif;Graphics;Viewer;
++MimeType=image/jpeg;image/tiff;image/png;
++Icon=ida