summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-04-12 09:33:40 -0600
committerTim Harder <radhermit@gentoo.org>2020-04-12 09:48:42 -0600
commit6e7f3ccdecefaa8716371009e5543e34b2cc8fe4 (patch)
tree16713a67b4d99e16d6a5ee65b3cb981d020b7be5 /media-gfx/feh/feh-3.4.ebuild
parentacct-group/locate: new group (245) (diff)
downloadgentoo-6e7f3ccdecefaa8716371009e5543e34b2cc8fe4.tar.gz
gentoo-6e7f3ccdecefaa8716371009e5543e34b2cc8fe4.tar.bz2
gentoo-6e7f3ccdecefaa8716371009e5543e34b2cc8fe4.zip
media-gfx/feh: version bump to 3.4
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-gfx/feh/feh-3.4.ebuild')
-rw-r--r--media-gfx/feh/feh-3.4.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/media-gfx/feh/feh-3.4.ebuild b/media-gfx/feh/feh-3.4.ebuild
new file mode 100644
index 000000000000..cdfb177f990f
--- /dev/null
+++ b/media-gfx/feh/feh-3.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+HOMEPAGE="https://feh.finalrewind.org/"
+SRC_URI="https://feh.finalrewind.org/${P}.tar.bz2"
+
+LICENSE="feh"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="debug curl exif test xinerama"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="media-libs/imlib2[X]
+ >=media-libs/libpng-1.2:0=
+ x11-libs/libX11
+ curl? ( net-misc/curl )
+ exif? ( media-libs/libexif )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/jpeg:0"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXt
+ test? (
+ >=dev-lang/perl-5.10
+ dev-perl/Test-Command
+ media-libs/imlib2[gif,jpeg,png]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.2-debug-cflags.patch )
+
+pkg_setup() {
+ use_feh() { usex $1 1 0; }
+
+ fehopts=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ doc_dir='${main_dir}'/share/doc/${PF}
+ example_dir='${main_dir}'/share/doc/${PF}/examples
+ curl=$(use_feh curl)
+ debug=$(use_feh debug)
+ xinerama=$(use_feh xinerama)
+ exif=$(use_feh exif)
+ )
+}
+
+src_compile() {
+ tc-export CC
+ emake "${fehopts[@]}"
+}
+
+src_install() {
+ emake "${fehopts[@]}" install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}