summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDouglas Agbeve <douglas@agbeve.com>2021-07-26 18:06:31 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-27 14:18:34 -0400
commit80cad85eafac14c1f0a2215fbef101c4d5ef6513 (patch)
tree80fe97d6f558ede2063d61ba1be0d8793bdc3c44 /media-gfx/flameshot
parentnet-ftp/vsftpd: depend on virtual/libcrypt when pam is disabled (diff)
downloadgentoo-80cad85eafac14c1f0a2215fbef101c4d5ef6513.tar.gz
gentoo-80cad85eafac14c1f0a2215fbef101c4d5ef6513.tar.bz2
gentoo-80cad85eafac14c1f0a2215fbef101c4d5ef6513.zip
media-gfx/flameshot: bump to v0.10.1
Closes: https://bugs.gentoo.org/804576 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Douglas Agbeve <douglas@agbeve.com> Closes: https://github.com/gentoo/gentoo/pull/21794 Acked-by: Pavel Kalugin <pavel@pavelthebest.me> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/flameshot')
-rw-r--r--media-gfx/flameshot/Manifest1
-rw-r--r--media-gfx/flameshot/flameshot-0.10.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-gfx/flameshot/Manifest b/media-gfx/flameshot/Manifest
index 33e42fb44c6f..1d536a4b067f 100644
--- a/media-gfx/flameshot/Manifest
+++ b/media-gfx/flameshot/Manifest
@@ -1,2 +1,3 @@
+DIST flameshot-0.10.1.tar.gz 7726725 BLAKE2B 7045e7f86fc835a49a814b6fb86c2d413422a323925d358cc37d6263b8a1ca9415f134caf72700ebe138621a5687d9245dc96edf8f0597eb1e974edf5bf699f1 SHA512 dca9c48b284d23b67cb71ff78d79b87887506bf5b30600c5d9ee78f5fadebab6d507674abeeae0c5cdf4a149e71df60666299c7db10168613c03467c7aafa7cf
DIST flameshot-0.6.0.tar.gz 641561 BLAKE2B f9e87373d84c1a841f70cd9c13b504865a0ef23d0fb29848f2270171459afe9c6852e12c712ebdc7cf3cfc62214d7b7507b85cf21838d0ebed33bee1e39f4aad SHA512 194127032ab0f62a6ba2698688e11b2d4e6f0e04a282144f5fbb6c232eeebc71371af2d55abbb6e98b8649dee036e6f0a6ef55710e4321a60fd5ac6e453ab975
DIST flameshot-0.9.0.tar.gz 7659641 BLAKE2B 38151bf333802ccbaa6c2292799958fe4c75f5a978eea9b2314c5eb264fb569cfcce73afac79b80423686d3a10ec54300ad4cacd3be9a6c6e58c72f59c23fb46 SHA512 888422cd66b7c90cd6da0e824a2c12c0ca7e3cfdfd0a0499868acf9609e6c3a0977f816c656690fa101971b98a3f560cf7849b93079c091b25155360cb20ea11
diff --git a/media-gfx/flameshot/flameshot-0.10.1.ebuild b/media-gfx/flameshot/flameshot-0.10.1.ebuild
new file mode 100644
index 000000000000..ae9c8e477d2f
--- /dev/null
+++ b/media-gfx/flameshot/flameshot-0.10.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Powerful yet simple to use screenshot software"
+HOMEPAGE="https://flameshot.org https://github.com/flameshot-org/flameshot"
+SRC_URI="https://github.com/flameshot-org/flameshot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 Free-Art-1.3 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ =dev-qt/qtsingleapplication-2.6*[qt5(+),X]
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtdbus:5
+ sys-apps/dbus
+ dev-libs/spdlog:=
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -r external/spdlog || die
+ rm -r external/singleapplication || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_EXTERNAL_SPDLOG=1
+ -DUSE_EXTERNAL_SINGLEAPPLICATION=1
+ -DENABLE_CACHE=0
+ )
+
+ cmake_src_configure
+}