summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2018-11-27 22:29:52 +0330
committerSobhan Mohammadpour <sobhan@gentoo.org>2018-11-27 22:29:52 +0330
commit9ec94340d3008d1c006558de6c09fb132a1ec336 (patch)
tree04c88703685ee66bd9f3ef7d6d12f0e7774f84e1 /media-gfx/frogr
parentmedia-libs/opencv: fix typo (diff)
downloadgentoo-9ec94340d3008d1c006558de6c09fb132a1ec336.tar.gz
gentoo-9ec94340d3008d1c006558de6c09fb132a1ec336.tar.bz2
gentoo-9ec94340d3008d1c006558de6c09fb132a1ec336.zip
media-gfx/frogr: bump 1.3 → 1.5
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
Diffstat (limited to 'media-gfx/frogr')
-rw-r--r--media-gfx/frogr/Manifest1
-rw-r--r--media-gfx/frogr/frogr-1.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-gfx/frogr/Manifest b/media-gfx/frogr/Manifest
index c6bd342b3718..4c6c522f738d 100644
--- a/media-gfx/frogr/Manifest
+++ b/media-gfx/frogr/Manifest
@@ -1 +1,2 @@
DIST frogr-1.3.tar.xz 2552456 BLAKE2B 562f88898fec153c50696dce59b5396b6f9e88bc68cbf264e7954c2d2f402cb44cb2e6bf3c1c786d50285532c66167678f0fde053c317a0d23b6f4b210e69fa1 SHA512 82ca3ff1e97e7ff45bce1915f629809cc9efa6d33735b0e41b17bb8f69a31a2b035dd53045a3e56e7769d379b534a2468e37a684505438cfea70cc141103d1cb
+DIST frogr-1.5.tar.xz 2233600 BLAKE2B aeb04db0d5d57f470d377986f2e857ee63b47df85e9c3251cdfac8585efa19491650ecede0bfa95c157c2584298dc02173afec624bc439dcd8b52d101c465d54 SHA512 f4af5ec82ad1771e71387c40467fc697c7e3edff9f76ecd0f762e446d136a293477867cb7b6bc6d10bc0fdd95210b25f515eb56bf2d456f79009884019c44dd4
diff --git a/media-gfx/frogr/frogr-1.5.ebuild b/media-gfx/frogr/frogr-1.5.ebuild
new file mode 100644
index 000000000000..2cb753483f16
--- /dev/null
+++ b/media-gfx/frogr/frogr-1.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="flickr applications for GNOME"
+HOMEPAGE="https://live.gnome.org/Frogr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-1.2
+ >=x11-libs/gtk+-3.16:3[introspection]
+ >=media-libs/libexif-0.6.14
+ >=dev-libs/libxml2-2.6.8:2
+ media-libs/gstreamer:1.0
+ >=net-libs/libsoup-2.34:2.4
+ >=dev-libs/libgcrypt-1.5:*
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+# TODO add a useflag for enable-video or header-bar???
+
+src_configure() {
+ local emesonargs=()
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}