summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-10-01 18:57:31 +0200
committerDavid Seifert <soap@gentoo.org>2023-10-01 18:57:31 +0200
commit8540d29e1a7e96241bb845e3083fe577df2a26e7 (patch)
treeee972759ddd517a617d25f7bb137f4a346a8cd5d /media-gfx/gozer/gozer-0.7-r5.ebuild
parentwww-apps/rutorrent: bump version to 4.2.6 (diff)
downloadgentoo-8540d29e1a7e96241bb845e3083fe577df2a26e7.tar.gz
gentoo-8540d29e1a7e96241bb845e3083fe577df2a26e7.tar.bz2
gentoo-8540d29e1a7e96241bb845e3083fe577df2a26e7.zip
media-gfx/gozer: Fix call to undeclared library function strcmp
Closes: https://github.com/gentoo/gentoo/pull/33148 Closes: https://bugs.gentoo.org/896210 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx/gozer/gozer-0.7-r5.ebuild')
-rw-r--r--media-gfx/gozer/gozer-0.7-r5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/gozer/gozer-0.7-r5.ebuild b/media-gfx/gozer/gozer-0.7-r5.ebuild
new file mode 100644
index 000000000000..6dd3168d57a0
--- /dev/null
+++ b/media-gfx/gozer/gozer-0.7-r5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="tool for rendering arbitrary text as graphics, using ttfs and styles"
+HOMEPAGE="http://www.linuxbrit.co.uk/gozer/"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ media-libs/giblib
+ media-libs/imlib2
+"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libXext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-fix-build-with-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}