summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-29 14:13:40 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-29 14:41:33 +0200
commit479f4bb509d938aebb1cec837f19b588db261681 (patch)
treebc3e943160ebaef09c7f7bdfad08093b3ee2acc7 /media-gfx/gphoto2/gphoto2-2.5.10.ebuild
parentmedia-gfx/gphoto2: Drop old (diff)
downloadgentoo-479f4bb509d938aebb1cec837f19b588db261681.tar.gz
gentoo-479f4bb509d938aebb1cec837f19b588db261681.tar.bz2
gentoo-479f4bb509d938aebb1cec837f19b588db261681.zip
media-gfx/gphoto2: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-gfx/gphoto2/gphoto2-2.5.10.ebuild')
-rw-r--r--media-gfx/gphoto2/gphoto2-2.5.10.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-gfx/gphoto2/gphoto2-2.5.10.ebuild b/media-gfx/gphoto2/gphoto2-2.5.10.ebuild
new file mode 100644
index 000000000000..6398d124d0e3
--- /dev/null
+++ b/media-gfx/gphoto2/gphoto2-2.5.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Free, redistributable digital camera software application"
+HOMEPAGE="http://www.gphoto.org/"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aalib exif ncurses nls readline"
+
+# aalib -> needs libjpeg
+RDEPEND="
+ dev-libs/popt
+ >=media-libs/libgphoto2-2.5.6:=[exif?]
+ aalib? (
+ media-libs/aalib
+ virtual/jpeg:0 )
+ exif? ( media-libs/libexif )
+ ncurses? ( dev-libs/cdk )
+ readline? ( sys-libs/readline:0 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.14.1 )
+"
+
+src_prepare() {
+ default
+ # Leave GCC debug builds under user control
+ sed -r '/(C|LD)FLAGS/ s/ -g( |")/\1/' \
+ -i configure{.ac,} || die
+ eautoreconf
+}
+
+src_configure() {
+ CPPFLAGS="-I/usr/include/cdk" \
+ econf \
+ $(use_with aalib) \
+ $(use_with aalib jpeg) \
+ $(use_with exif libexif auto) \
+ $(use_with ncurses cdk) \
+ $(use_enable nls) \
+ $(use_with readline)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ HTML_DIR="${D}"/usr/share/doc/${PF}/sgml \
+ install
+
+ einstalldocs
+ rm -rf "${D}"/usr/share/doc/${PF}/sgml/gphoto2
+}