summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/graphicsmagick/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/graphicsmagick/files')
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.16-libpng14.patch65
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch32
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-freetype.patch32
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-powerpc.patch11
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-flags.patch56
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-freetype.patch15
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-perl.patch13
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch20
8 files changed, 244 insertions, 0 deletions
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.16-libpng14.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.16-libpng14.patch
new file mode 100644
index 000000000000..bacf70e9ec24
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.16-libpng14.patch
@@ -0,0 +1,65 @@
+
+# HG changeset patch
+# User Glenn Randers-Pehrson <glennrp@simple...>
+# Date 1343491548 18000
+# Node ID d6e469d02cd260b6531e86a8a6c8a5a2b9ff51cb
+# Parent fe9e2eb655ce8b85abfd9b88d20a8a1648ad71e7
+coders/png.c: Some typecasts were inconsistent with libpng-1.4 and later.
+
+diff -r fe9e2eb655ce -r d6e469d02cd2 coders/png.c
+--- a/coders/png.c Thu Jul 26 20:24:26 2012 -0500
++++ b/coders/png.c Sat Jul 28 11:05:48 2012 -0500
+@@ -1360,7 +1360,11 @@
+ }
+
+ #ifdef PNG_USER_MEM_SUPPORTED
+-static png_voidp png_IM_malloc(png_structp png_ptr,png_uint_32 size)
++#if PNG_LIBPNG_VER >= 14000
++static png_voidp png_IM_malloc(png_structp png_ptr,png_alloc_size_t size)
++#else
++static png_voidp png_IM_malloc(png_structp png_ptr,png_size_t size)
++#endif
+ {
+ (void) png_ptr;
+ return MagickAllocateMemory(png_voidp,(size_t) size);
+@@ -6169,12 +6173,22 @@
+ (void) printf("writing raw profile: type=%.1024s, length=%lu\n",
+ profile_type, (unsigned long)length);
+ }
+- text=(png_textp) png_malloc(ping,(png_uint_32) sizeof(png_text));
++#if PNG_LIBPNG_VER >= 14000
++ text=(png_textp) png_malloc(ping,(png_alloc_size_t) sizeof(png_text));
++#else
++ text=(png_textp) png_malloc(ping,(png_size_t) sizeof(png_text));
++#endif
+ description_length=strlen((const char *) profile_description);
+ allocated_length=(png_uint_32) (length*2 + (length >> 5) + 20
+ + description_length);
+- text[0].text=(png_charp) png_malloc(ping,allocated_length);
+- text[0].key=(png_charp) png_malloc(ping, (png_uint_32) 80);
++#if PNG_LIBPNG_VER >= 14000
++ text[0].text=(png_charp) png_malloc(ping,
++ (png_alloc_size_t) allocated_length);
++ text[0].key=(png_charp) png_malloc(ping, (png_alloc_size_t) 80);
++#else
++ text[0].text=(png_charp) png_malloc(ping, (png_size_t) allocated_length);
++ text[0].key=(png_charp) png_malloc(ping, (png_size_t) 80);
++#endif
+ text[0].key[0]='\0';
+ (void) strcat(text[0].key, "Raw profile type ");
+ (void) strncat(text[0].key, (const char *) profile_type, 61);
+@@ -7620,7 +7634,12 @@
+
+ if (*attribute->key == '[')
+ continue;
+- text=(png_textp) png_malloc(ping,(png_uint_32) sizeof(png_text));
++#if PNG_LIBPNG_VER >= 14000
++ text=(png_textp) png_malloc(ping,
++ (png_alloc_size_t) sizeof(png_text));
++#else
++ text=(png_textp) png_malloc(ping,(png_size_t) sizeof(png_text));
++#endif
+ text[0].key=attribute->key;
+ text[0].text=attribute->value;
+ text[0].text_length=strlen(attribute->value);
+
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch
new file mode 100644
index 000000000000..3ae4ad49f00b
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch
@@ -0,0 +1,32 @@
+https://sourceforge.net/tracker/?func=detail&aid=3601612&group_id=73485&atid=537940
+
+--- a/configure
++++ b/configure
+@@ -26488,7 +26488,6 @@
+ # directory as GraphicsMagick installation prefix.
+ #LDFLAGS="$LDFLAGS -L$LIB_DIR"
+ #CPPFLAGS="$CPPFLAGS -I$INCLUDE_DIR"
+-MAGICK_API_CPPFLAGS="-I$INCLUDE_DIR/GraphicsMagick $MAGICK_API_CPPFLAGS"
+
+ #
+ # Find the X11 RGB database
+@@ -29490,8 +29490,8 @@
+ then
+ freetype_prefix=`${freetype_config} --prefix`
+ freetype_exec_prefix=`${freetype_config} --exec-prefix`
+- LDFLAGS="$LDFLAGS -L${freetype_exec_prefix}/lib"
+- CPPFLAGS="$CPPFLAGS -I${freetype_prefix}/include/freetype2"
++ LDFLAGS="$LDFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --libs`"
++ CPPFLAGS="$CPPFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --cflags`"
+ fi
+
+ dnl First see if there is a library
+@@ -35767,7 +35767,7 @@
+
+ MAGICK_API_CFLAGS=$CFLAGS
+ MAGICK_API_CPPFLAGS=`echo $MAGICK_API_CPPFLAGS | sed -e 's/ */ /g'`
+-MAGICK_API_LDFLAGS="-L$LIB_DIR $LDFLAGS"
++MAGICK_API_LDFLAGS="$LDFLAGS"
+ MAGICK_API_DEP_LIBS="$MAGICK_DEP_LIBS $MAGICK_API_LIBLTDL"
+ MAGICK_API_LIBS="-lGraphicsMagick $MAGICK_API_DEP_LIBS"
+
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-freetype.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-freetype.patch
new file mode 100644
index 000000000000..d6504e6d0ffe
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-freetype.patch
@@ -0,0 +1,32 @@
+https://sourceforge.net/tracker/?func=detail&aid=3601612&group_id=73485&atid=537940
+
+--- GraphicsMagick-1.3.18/configure
++++ GraphicsMagick-1.3.18/configure
+@@ -22249,7 +22249,6 @@
+ # directory as GraphicsMagick installation prefix.
+ #LDFLAGS="$LDFLAGS -L$LIB_DIR"
+ #CPPFLAGS="$CPPFLAGS -I$INCLUDE_DIR"
+-MAGICK_API_CPPFLAGS="-I$INCLUDE_DIR/GraphicsMagick $MAGICK_API_CPPFLAGS"
+
+ #
+ # Find the X11 RGB database
+@@ -25994,8 +25993,8 @@
+ then
+ freetype_prefix=`${freetype_config} --prefix`
+ freetype_exec_prefix=`${freetype_config} --exec-prefix`
+- LDFLAGS="$LDFLAGS -L${freetype_exec_prefix}/lib"
+- CPPFLAGS="$CPPFLAGS -I${freetype_prefix}/include/freetype2"
++ LDFLAGS="$LDFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --libs`"
++ CPPFLAGS="$CPPFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --cflags`"
+ fi
+
+ if test "$LIB_TTF" = ''
+@@ -29605,7 +29604,7 @@
+
+ MAGICK_API_CFLAGS=$CFLAGS
+ MAGICK_API_CPPFLAGS=`echo $MAGICK_API_CPPFLAGS | sed -e 's/ */ /g'`
+-MAGICK_API_LDFLAGS="-L$LIB_DIR $LDFLAGS"
++MAGICK_API_LDFLAGS="$LDFLAGS"
+ MAGICK_API_DEP_LIBS="$MAGICK_DEP_LIBS"
+ MAGICK_API_LIBS="-lGraphicsMagick $MAGICK_API_DEP_LIBS"
+
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-powerpc.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-powerpc.patch
new file mode 100644
index 000000000000..30a67fdc3e2d
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.18-powerpc.patch
@@ -0,0 +1,11 @@
+--- a/magick/studio.h
++++ b/magick/studio.h
+@@ -51,7 +51,7 @@
+ threads. Most CPUs have cache lines of 32 or 64 bytes. IBM Power CPUs have
+ cache lines of 128 bytes.
+ */
+-#if defined(MAGICK_TARGET_CPU) && (MAGICK_TARGET_CPU == powerpc)
++#ifdef __powerpc__
+ # define MAGICK_CACHE_LINE_SIZE 128
+ #else
+ # define MAGICK_CACHE_LINE_SIZE 64
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-flags.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-flags.patch
new file mode 100644
index 000000000000..1ebef5400337
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-flags.patch
@@ -0,0 +1,56 @@
+Fix various preprocessor, compiler, and linker flags added to config wrappers.
+Previously they would add build time flags to the files which is incorrect.
+
+--- GraphicsMagick-1.3.19/configure.ac
++++ GraphicsMagick-1.3.19/configure.ac
+@@ -346,6 +346,7 @@
+
+ AC_OPENMP([C])
+ CFLAGS="$OPENMP_CFLAGS $CFLAGS"
++MAGICK_API_CFLAGS="$MAGICK_API_CFLAGS $OPENMP_CFLAGS"
+ #CXXFLAGS="$OPENMP_CXXFLAGS $CXXFLAGS"
+ #LDFLAGS="$LDFLAGS $OPENMP_CFLAGS"
+ AC_SUBST(OPENMP_CFLAGS)
+@@ -3407,9 +3408,10 @@
+ MAGICK_DEP_LIBS=`echo $MAGICK_DEP_LIBS | sed -e 's/ */ /g'`
+ #LIBS=`echo $LIBS | sed -e 's/ */ /g'`
+
+-MAGICK_API_CFLAGS=$CFLAGS
++MAGICK_API_CFLAGS=`echo $MAGICK_API_CFLAGS | sed -e 's/ */ /g'`
+ MAGICK_API_CPPFLAGS=`echo $MAGICK_API_CPPFLAGS | sed -e 's/ */ /g'`
+-MAGICK_API_LDFLAGS="-L$LIB_DIR $LDFLAGS"
++MAGICK_API_CXXFLAGS=""
++MAGICK_API_LDFLAGS="-L$LIB_DIR"
+ MAGICK_API_DEP_LIBS="$MAGICK_DEP_LIBS"
+ MAGICK_API_LIBS="-lGraphicsMagick $MAGICK_API_DEP_LIBS"
+
+@@ -3440,6 +3442,7 @@
+
+ AC_SUBST(MAGICK_API_CFLAGS)
+ AC_SUBST(MAGICK_API_CPPFLAGS)
++AC_SUBST(MAGICK_API_CXXFLAGS)
+ AC_SUBST(MAGICK_API_PC_CPPFLAGS)
+ AC_SUBST(MAGICK_API_LDFLAGS)
+ AC_SUBST(MAGICK_API_LIBS)
+--- GraphicsMagick-1.3.19/magick/GraphicsMagick-config.in
++++ GraphicsMagick-1.3.19/magick/GraphicsMagick-config.in
+@@ -30,7 +30,7 @@
+ echo @PACKAGE_VERSION@
+ ;;
+ --cflags)
+- echo '@CFLAGS@'
++ echo '@MAGICK_API_CFLAGS@'
+ ;;
+ --cppflags)
+ echo '@MAGICK_API_CPPFLAGS@'
+--- GraphicsMagick-1.3.19/Magick++/bin/GraphicsMagick++-config.in
++++ GraphicsMagick-1.3.19/Magick++/bin/GraphicsMagick++-config.in
+@@ -33,7 +33,7 @@
+ echo '@MAGICK_API_CPPFLAGS@'
+ ;;
+ --cxxflags)
+- echo '@CXXFLAGS@'
++ echo '@MAGICK_API_CXXFLAGS@'
+ ;;
+ --ldflags)
+ echo '@MAGICK_API_LDFLAGS@'
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-freetype.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-freetype.patch
new file mode 100644
index 000000000000..4ef1fb997edc
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-freetype.patch
@@ -0,0 +1,15 @@
+https://sourceforge.net/tracker/?func=detail&aid=3601612&group_id=73485&atid=537940
+
+--- GraphicsMagick-1.3.19/configure.ac
++++ GraphicsMagick-1.3.19/configure.ac
+@@ -2283,8 +2284,8 @@
+ then
+ freetype_prefix=`${freetype_config} --prefix`
+ freetype_exec_prefix=`${freetype_config} --exec-prefix`
+- LDFLAGS="$LDFLAGS -L${freetype_exec_prefix}/lib"
+- CPPFLAGS="$CPPFLAGS -I${freetype_prefix}/include/freetype2"
++ LDFLAGS="$LDFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --libs`"
++ CPPFLAGS="$CPPFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --cflags`"
+ fi
+
+ dnl First see if there is a library
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-perl.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-perl.patch
new file mode 100644
index 000000000000..39cf05fd55f1
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.19-perl.patch
@@ -0,0 +1,13 @@
+Link perl bindings against built libraries instead of system libraries (bug #456180).
+
+--- GraphicsMagick-1.3.19/PerlMagick/Makefile.PL.in
++++ GraphicsMagick-1.3.19/PerlMagick/Makefile.PL.in
+@@ -23,7 +23,7 @@
+ my $magick_BIN_DIR="$ENV{'DESTDIR'}@BIN_DIR@";
+ my $magick_DEP_LIBS='@MAGICK_DEP_LIBS@';
+ my $magick_PERLMAINCC='@PERLMAINCC@';
+-my $magick_LIB_DIR="$ENV{'DESTDIR'}@MAGICKLIBDIR@";
++my $magick_LIB_DIR="../magick/.libs";
+
+ # Compute test specification
+ my $delegate_tests='t/*.t';
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch
new file mode 100644
index 000000000000..44a13581e42a
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch
@@ -0,0 +1,20 @@
+--- GraphicsMagick-1.3.20/magick/studio.h
++++ GraphicsMagick-1.3.20/magick/studio.h
+@@ -51,12 +51,11 @@
+ threads. Most CPUs have cache lines of 32 or 64 bytes. IBM Power CPUs have
+ cache lines of 128 bytes.
+ */
+-/* FIXME: C pre-processor does not support comparing strings. */
+-/* #if defined(MAGICK_TARGET_CPU) && (MAGICK_TARGET_CPU == powerpc) */
+-/* # define MAGICK_CACHE_LINE_SIZE 128 */
+-/* #else */
+-# define MAGICK_CACHE_LINE_SIZE 64
+-/* #endif */
++#ifdef __powerpc__
++#define MAGICK_CACHE_LINE_SIZE 128
++#else
++#define MAGICK_CACHE_LINE_SIZE 64
++#endif
+
+
+ /*