summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-27 00:19:57 +0000
committerSam James <sam@gentoo.org>2022-03-27 00:24:09 +0000
commit809d96b4c6ed7975726e1ce1b94e8ac1147a0473 (patch)
tree11c7ad3c2553e041601baad0ce11977875d114d8 /media-gfx/graphicsmagick
parentnet-dns/unbound: specify dependency location from sysroot (diff)
downloadgentoo-809d96b4c6ed7975726e1ce1b94e8ac1147a0473.tar.gz
gentoo-809d96b4c6ed7975726e1ce1b94e8ac1147a0473.tar.bz2
gentoo-809d96b4c6ed7975726e1ce1b94e8ac1147a0473.zip
media-gfx/graphicsmagick: sync live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/graphicsmagick')
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-9999.ebuild39
1 files changed, 27 insertions, 12 deletions
diff --git a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
index 06f0f8f71c40..c640b1b4cc74 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
@@ -9,10 +9,11 @@ MY_P=${P/graphicsm/GraphicsM}
DESCRIPTION="Collection of tools and libraries for many image formats"
HOMEPAGE="http://www.graphicsmagick.org/ http://hg.code.sf.net/p/graphicsmagick/code/"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit mercurial
EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/bobfriesenhahn.asc
inherit verify-sig
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
SRC_URI+=" verify-sig? ( mirror://sourceforge/${PN}/${MY_P}.tar.xz.sig )"
@@ -26,23 +27,25 @@ fi
LICENSE="MIT"
SLOT="0/${PV%.*}"
-IUSE="bzip2 +cxx debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma"
+IUSE="bzip2 +cxx debug dynamic-loading fpx heif imagemagick jbig jpeg jpegxl lcms lzma"
IUSE+=" openmp perl png postscript q16 q32 static-libs svg threads tiff truetype"
IUSE+=" webp wmf X zlib"
-RDEPEND="dev-libs/libltdl:0
+RDEPEND="dev-libs/libltdl
bzip2? ( app-arch/bzip2 )
fpx? ( media-libs/libfpx )
+ heif? ( media-libs/libheif:= )
imagemagick? ( !media-gfx/imagemagick )
jbig? ( media-libs/jbigkit )
- jpeg? ( virtual/jpeg:0 )
+ jpeg? ( virtual/jpeg )
+ jpegxl? ( media-libs/libjxl:= )
lcms? ( media-libs/lcms:2 )
lzma? ( app-arch/xz-utils )
perl? ( dev-lang/perl:= )
- png? ( media-libs/libpng:0= )
+ png? ( media-libs/libpng:= )
postscript? ( app-text/ghostscript-gpl )
svg? ( dev-libs/libxml2 )
- tiff? ( media-libs/tiff:0 )
+ tiff? ( media-libs/tiff )
truetype? (
media-fonts/urw-fonts
>=media-libs/freetype-2
@@ -61,6 +64,14 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.3.19-perl.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_prepare() {
default
@@ -69,16 +80,11 @@ src_prepare() {
src_configure() {
local depth=8
+
use q16 && depth=16
use q32 && depth=32
- local openmp=disable
- if use openmp && tc-has-openmp ; then
- openmp=enable
- fi
-
local myeconfargs=(
- --${openmp}-openmp
--enable-largefile
--enable-shared
$(use_enable static-libs static)
@@ -90,6 +96,8 @@ src_configure() {
--with-quantum-depth=${depth}
--without-frozenpaths
$(use_with cxx magick-plus-plus)
+ $(use_with heif)
+ $(use_with jpegxl jxl)
$(use_with perl)
--with-perl-options=INSTALLDIRS=vendor
$(use_with bzip2 bzlib)
@@ -113,6 +121,12 @@ src_configure() {
$(use_with X x)
)
+ if use openmp && tc-has-openmp ; then
+ myeconfargs+=( --enable-openmp )
+ else
+ myeconfargs+=( --disable-openmp )
+ fi
+
econf "${myeconfargs[@]}"
}
@@ -133,6 +147,7 @@ src_install() {
if use perl ; then
emake -C PerlMagick DESTDIR="${D}" install
+
find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
fi