summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-12-06 19:40:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-12-06 20:40:40 +0100
commitac733551256da143fbfd66d1f2c70c5513d50292 (patch)
tree554ad341d3e73a3de6bca1d3744500c0e4c586a8 /media-gfx/graphite2
parentdev-lang/python: disable _ctypes, _crypt for cross (CBUILD) Python (diff)
downloadgentoo-ac733551256da143fbfd66d1f2c70c5513d50292.tar.gz
gentoo-ac733551256da143fbfd66d1f2c70c5513d50292.tar.bz2
gentoo-ac733551256da143fbfd66d1f2c70c5513d50292.zip
media-gfx/graphite2: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/28574 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/graphite2')
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch45
-rw-r--r--media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch18
2 files changed, 0 insertions, 63 deletions
diff --git a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch b/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
deleted file mode 100644
index a7e5804319d7..000000000000
--- a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-https://bugs.gentoo.org/829690
-
-See https://github.com/silnrsi/graphite/pull/44.
-
-Drop -nodefaultlibs:
-- graphite is written in C++ which makes avoiding libstdc++ (or libc++) a dubious
- goal;
-- this ends up breaking e.g. x86/musl because we need to inject -lssp_nonshared,
- but it wouldn't be surprising if it broke other exotic targets too.
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -105,7 +105,7 @@ set_target_properties(graphite2 PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
-@@ -135,7 +135,6 @@ endif()
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Darwin")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wimplicit-fallthrough -Wendif-labels -Wshadow -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -47,12 +47,12 @@ else (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
- set_target_properties(graphite2-base PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- set_target_properties(graphite2-file PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING${TELEMETRY}"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- endif()
-
diff --git a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch b/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
deleted file mode 100644
index b162ca9aa6f9..000000000000
--- a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://src.fedoraproject.org/rpms/graphite2/raw/41fb7c104c8f9293254abaa91bbda1daafb458cd/f/graphite-arm-nodefaultlibs.patch
-https://bugs.gentoo.org/829690
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -120,11 +120,7 @@
- if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
- target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
- else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
-- if (GRAPHITE2_SANITIZERS)
-- target_link_libraries(graphite2 c gcc_s)
-- else ()
-- target_link_libraries(graphite2 c gcc)
-- endif ()
-+ target_link_libraries(graphite2 c gcc_s)
- endif()
- include(Graphite)
- if (BUILD_SHARED_LIBS)
-