summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:39:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:40:23 +0100
commite630067021daa4554261067cf3398a9a3d1fac1f (patch)
treed3f18799812075c1aa3dcc1803cd011cc77a0581 /media-gfx/graphite2
parentmedia-sound/spotify: add missing dep on at-spi2-atk (diff)
downloadgentoo-e630067021daa4554261067cf3398a9a3d1fac1f.tar.gz
gentoo-e630067021daa4554261067cf3398a9a3d1fac1f.tar.bz2
gentoo-e630067021daa4554261067cf3398a9a3d1fac1f.zip
media-gfx/graphite2: Switch to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/graphite2')
-rw-r--r--media-gfx/graphite2/graphite2-1.3.13.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-gfx/graphite2/graphite2-1.3.13.ebuild b/media-gfx/graphite2/graphite2-1.3.13.ebuild
index afb99b3c7fe6..a297b8ce652c 100644
--- a/media-gfx/graphite2/graphite2-1.3.13.ebuild
+++ b/media-gfx/graphite2/graphite2-1.3.13.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
+CMAKE_ECLASS=cmake
GENTOO_DEPEND_ON_PERL="no"
inherit perl-module python-any-r1 cmake-multilib
@@ -47,7 +48,7 @@ python_check_deps() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# make tests optional
if ! use test; then
@@ -65,11 +66,11 @@ multilib_src_configure() {
-DGRAPHITE2_NSEGCACHE:BOOL=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
# fix perl linking
if multilib_is_native_abi && use perl; then
- # we rely on the fact that cmake-utils_src_configure sets BUILD_DIR
+ # we rely on the fact that cmake_src_configure sets BUILD_DIR
sed -e "s:@BUILD_DIR@:\"${BUILD_DIR}/src\":" \
-i "${S}"/contrib/perl/Build.PL || die
fi
@@ -86,7 +87,7 @@ src_compile() {
multilib_src_test() {
if multilib_is_native_abi; then
- cmake-utils_src_test
+ cmake_src_test
else
einfo "Cannot test since python is not multilib."
fi