summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-01-02 19:54:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-02 19:54:47 +0200
commit8a7966781c218c5402a171b717322c9773134610 (patch)
tree09483111632907c3bb09299d799f8ad96a74aed7 /media-gfx/inkscape
parentgnustep-base/gnustep-gui: use virtualx for testing (diff)
downloadgentoo-8a7966781c218c5402a171b717322c9773134610.tar.gz
gentoo-8a7966781c218c5402a171b717322c9773134610.tar.bz2
gentoo-8a7966781c218c5402a171b717322c9773134610.zip
media-gfx/inkscape: fix sandbox issue with 1.0.1
Closes: https://bugs.gentoo.org/761915 Closes: https://github.com/gentoo/gentoo/pull/18911 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/inkscape-1.0.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/media-gfx/inkscape/inkscape-1.0.1.ebuild b/media-gfx/inkscape/inkscape-1.0.1.ebuild
index 46527098d103..ebd89f20c15d 100644
--- a/media-gfx/inkscape/inkscape-1.0.1.ebuild
+++ b/media-gfx/inkscape/inkscape-1.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -155,4 +155,7 @@ src_install() {
if [[ -e "${extdir}" ]] && [[ -n $(find "${extdir}" -mindepth 1) ]]; then
python_optimize "${ED}"/usr/share/${PN}/extensions
fi
+
+ # Empty directory causes sandbox issues, see bug #761915
+ rm -r "${ED}/usr/share/inkscape/fonts" || die "Failed to remove fonts directory."
}