summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-18 20:49:25 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-18 22:30:20 +0100
commitc93f64cd7214c6005652bac39f92db41724a17b4 (patch)
tree0516679b59fa6c5a944f40d06ef2e0c4ae1e64b1 /media-gfx/inkscape
parentmedia-gfx/inkscape: use internal 2geom explicitly (diff)
downloadgentoo-c93f64cd7214c6005652bac39f92db41724a17b4.tar.gz
gentoo-c93f64cd7214c6005652bac39f92db41724a17b4.tar.bz2
gentoo-c93f64cd7214c6005652bac39f92db41724a17b4.zip
media-gfx/inkscape: minor fixes, also from live ebuild
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/inkscape-1.1.2.ebuild37
-rw-r--r--media-gfx/inkscape/inkscape-9999.ebuild4
2 files changed, 31 insertions, 10 deletions
diff --git a/media-gfx/inkscape/inkscape-1.1.2.ebuild b/media-gfx/inkscape/inkscape-1.1.2.ebuild
index c966f1a88c05..58011f3429ba 100644
--- a/media-gfx/inkscape/inkscape-1.1.2.ebuild
+++ b/media-gfx/inkscape/inkscape-1.1.2.ebuild
@@ -5,18 +5,24 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml"
-
+MY_P="${P/_/}"
inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
+else
+ SRC_URI="https://media.inkscape.org/dl/resources/file/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
DESCRIPTION="SVG based generic vector-drawing program"
HOMEPAGE="https://inkscape.org/"
-SRC_URI="https://media.inkscape.org/dl/resources/file/${P}.tar.xz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="cdr dbus dia exif graphicsmagick imagemagick inkjar jemalloc jpeg
-openmp postscript readline spell svg2 visio wpg"
+openmp postscript readline spell svg2 test visio wpg"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -91,11 +97,13 @@ RDEPEND="${COMMON_DEPEND}
dia? ( app-office/dia )
postscript? ( app-text/ghostscript-gpl )
"
-DEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-cpp/gtest )
+"
-RESTRICT="test"
+RESTRICT="!test? ( test )"
-S="${WORKDIR}/${P}_2022-02-04_0a00cf5339"
+S="${WORKDIR}/${MY_P}"
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
@@ -103,6 +111,15 @@ pkg_pretend() {
fi
}
+src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+ [[ -d "${S}" ]] || mv -v "${WORKDIR}/${P}_202"?-??-* "${S}" || die
+}
+
src_prepare() {
cmake_src_prepare
sed -i "/install.*COPYING/d" CMakeScripts/ConfigCPack.cmake || die
@@ -119,7 +136,7 @@ src_configure() {
-DENABLE_POPPLER_CAIRO=ON
-DWITH_PROFILING=OFF
-DWITH_INTERNAL_2GEOM=ON
- -DBUILD_TESTING=OFF
+ -DBUILD_TESTING=$(usex test)
-DWITH_LIBCDR=$(usex cdr)
-DWITH_DBUS=$(usex dbus)
-DWITH_IMAGE_MAGICK=$(usex imagemagick $(usex !graphicsmagick)) # requires ImageMagick 6, only IM must be enabled
@@ -138,6 +155,10 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ cmake_build -j1 check
+}
+
src_install() {
cmake_src_install
diff --git a/media-gfx/inkscape/inkscape-9999.ebuild b/media-gfx/inkscape/inkscape-9999.ebuild
index 70cee13a08d3..58011f3429ba 100644
--- a/media-gfx/inkscape/inkscape-9999.ebuild
+++ b/media-gfx/inkscape/inkscape-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml"
@@ -13,7 +13,7 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
else
SRC_URI="https://media.inkscape.org/dl/resources/file/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="SVG based generic vector-drawing program"