summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-07-05 14:43:44 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-25 17:58:51 +0200
commitce969302196f7f415bcc683bca0d078024fec945 (patch)
tree15695fd6d42c5f5b0f07c8222bd3c14a73f7d482 /media-gfx/inkscape
parentdev-libs/libretls: version bump to 3.3.4 (diff)
downloadgentoo-ce969302196f7f415bcc683bca0d078024fec945.tar.gz
gentoo-ce969302196f7f415bcc683bca0d078024fec945.tar.bz2
gentoo-ce969302196f7f415bcc683bca0d078024fec945.zip
media-gfx/inkscape: sync live
- Add optional readline support, - gtkspell dependency was changed to gspell and aspell is not required anymore, - testing Closes: https://bugs.gentoo.org/790269 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/inkscape-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/media-gfx/inkscape/inkscape-9999.ebuild b/media-gfx/inkscape/inkscape-9999.ebuild
index 6912d66bb360..dc4abef7db64 100644
--- a/media-gfx/inkscape/inkscape-9999.ebuild
+++ b/media-gfx/inkscape/inkscape-9999.ebuild
@@ -16,7 +16,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS=""
IUSE="cdr dbus dia exif graphicsmagick imagemagick inkjar jemalloc jpeg lcms
-openmp postscript spell static-libs svg2 visio wpg"
+openmp postscript readline spell static-libs svg2 test visio wpg"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -67,10 +67,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
jemalloc? ( dev-libs/jemalloc )
jpeg? ( virtual/jpeg:0 )
lcms? ( media-libs/lcms:2 )
- spell? (
- app-text/aspell
- app-text/gtkspell:3
- )
+ readline? ( sys-libs/readline:= )
+ spell? ( app-text/gspell )
visio? (
app-text/libwpg:0.3
dev-libs/librevenge
@@ -94,9 +92,10 @@ RDEPEND="${COMMON_DEPEND}
"
DEPEND="${COMMON_DEPEND}
>=dev-libs/boost-1.65
+ test? ( dev-cpp/gtest )
"
-RESTRICT="test"
+RESTRICT="!test? ( test )"
S="${WORKDIR}/${MY_P}"
@@ -121,10 +120,13 @@ src_configure() {
-DENABLE_POPPLER=ON
-DENABLE_POPPLER_CAIRO=ON
-DWITH_PROFILING=OFF
+ -DBUILD_TESTING=$(usex test)
-DWITH_LIBCDR=$(usex cdr)
-DWITH_DBUS=$(usex dbus)
-DWITH_IMAGE_MAGICK=$(usex imagemagick $(usex !graphicsmagick)) # requires ImageMagick 6, only IM must be enabled
-DWITH_GRAPHICS_MAGICK=$(usex graphicsmagick $(usex imagemagick)) # both must be enabled to use GraphicsMagick
+ -DWITH_GNU_READLINE=$(usex readline)
+ -DWITH_GSPELL=$(usex spell)
-DWITH_JEMALLOC=$(usex jemalloc)
-DENABLE_LCMS=$(usex lcms)
-DWITH_OPENMP=$(usex openmp)
@@ -156,3 +158,7 @@ src_install() {
# Empty directory causes sandbox issues, see bug #761915
rm -r "${ED}/usr/share/inkscape/fonts" || die "Failed to remove fonts directory."
}
+
+src_test() {
+ cmake_build -j1 check
+}