summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan/iscan-2.30.1.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan/iscan-2.30.1.1.ebuild')
-rw-r--r--media-gfx/iscan/iscan-2.30.1.1.ebuild180
1 files changed, 180 insertions, 0 deletions
diff --git a/media-gfx/iscan/iscan-2.30.1.1.ebuild b/media-gfx/iscan/iscan-2.30.1.1.ebuild
new file mode 100644
index 000000000000..bcd4154f350e
--- /dev/null
+++ b/media-gfx/iscan/iscan-2.30.1.1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic autotools versionator
+
+# HINTS:
+# -> non-free modules are x86 and amd64 only
+# -> iscan frontend needs non-free modules
+# -> sane-epkowa should be usable on every arch
+# -> ${P}-${SRC_REV}.tar.gz (for gcc 3.2/3.3)
+# -> ${P}-${SRC_REV}.c2.tar.gz (for gcc 3.4 or later)
+
+# FIXME:
+# Make jpeg/png optional. The problem is, that the configure script ignores --disable-*,
+# if the corresponding lib is found on the system.
+# Furthermore, iscan doesn't compile w/o libusb, this should be fixed somehow.
+
+# TODO:
+# (re)add closed-source binary modules which are needed for some scanners.
+
+KEYWORDS="amd64 x86"
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+MY_DOC="userg_revQ"
+
+DESCRIPTION="EPSON Image Scan! for Linux (including sane-epkowa backend)"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# Use a gentoo hosted url since upstream uses a session based url that causes the
+# files to no longer be available after the session expires.
+SRC_URI="
+ http://dev.gentoo.org/~idella4/tarballs/${PN}_${MY_PVR}.tar.gz
+ http://dev.gentoo.org/~flameeyes/avasys/${PN}_${MY_PVR}.tar.gz
+ doc? (
+ http://dev.gentoo.org/~flameeyes/avasys/${MY_DOC}_e.pdf
+ linguas_ja? ( http://dev.gentoo.org/~flameeyes/avasys/${MY_DOC}_j.pdf )
+ )"
+LICENSE="GPL-2 AVASYS"
+SLOT="0"
+
+IUSE="X doc gimp jpeg png tiff"
+IUSE_LINGUAS="ar de es fr it ja ko nl pt zh_CN zh_TW"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+REQUIRED_USE="gimp? ( X )
+ jpeg? ( X )
+ png? ( X )
+ tiff? ( X )"
+
+QA_PRESTRIPPED="usr/$(get_libdir)/libesmod.so.*"
+QA_TEXTRELS="${QA_PRESTRIPPED}"
+QA_FLAGS_IGNORED="${QA_PRESTRIPPED}"
+
+# Upstream ships broken sanity test
+RESTRICT="test"
+
+RDEPEND="dev-libs/libxml2
+ media-gfx/iscan-data
+ media-gfx/sane-backends
+ virtual/udev
+ virtual/libusb:1
+ X? ( x11-libs/gtk+:2 )
+ gimp? ( media-gfx/gimp )
+ jpeg? ( virtual/jpeg:= )
+ png? ( media-libs/libpng:= )
+ tiff? ( media-libs/tiff:= )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ X? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ local i
+
+ # convert japanese docs to UTF-8
+ if use linguas_ja; then
+ for i in {NEWS,README}.ja non-free/*.ja.txt; do
+ if [ -f "${i}" ]; then
+ echo ">>> Converting ${i} to UTF-8"
+ iconv -f eucjp -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ fi
+ done
+ fi
+
+ # disable checks for gtk+
+ if ! use X; then
+ sed -i -e "s:PKG_CHECK_MODULES(GTK,.*):AC_DEFINE([HAVE_GTK_2], 0):g" \
+ -e "s:\(PKG_CHECK_MODULES(GDK_IMLIB,.*)\):#\1:g" configure.ac || die
+ fi
+
+ epatch "${FILESDIR}"/iscan-2.29.1-drop-ltdl.patch
+ epatch "${FILESDIR}"/iscan-2.28.1.3+libpng-1.5.patch
+ epatch "${FILESDIR}"/iscan-2.29.1-png-libs.patch
+ epatch "${FILESDIR}"/iscan-2.30.1-fix-g++-test.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -D_GNU_SOURCE # needed for 'strndup'
+ # Fix selector box bug 388073
+ replace-flags "-O[0-9s]" "-O1"
+
+ local myconf=(
+ --enable-dependency-reduction
+ --disable-static
+ $(use_enable X frontend)
+ $(use_enable gimp)
+ $(use_enable jpeg)
+ $(use_enable png)
+ $(use_enable tiff)
+ )
+ econf ${myconf[@]}
+}
+
+src_install() {
+ local MY_LIB="/usr/$(get_libdir)"
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # install docs
+ dodoc AUTHORS NEWS README
+ use linguas_ja && dodoc NEWS.ja README.ja
+
+ # install sane config
+ insinto /etc/sane.d
+ doins backend/epkowa.conf
+
+ # install extra docs
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ if use linguas_ja; then
+ doins "${DISTDIR}/${MY_DOC}_j.pdf"
+ else
+ doins "${DISTDIR}/${MY_DOC}_e.pdf"
+ fi
+ fi
+
+ # link iscan so it is seen as a plugin in gimp
+ if use X && use gimp; then
+ local plugindir
+ if [ -x /usr/bin/gimptool ]; then
+ plugindir="$(gimptool --gimpplugindir)/plug-ins" || die "Failed to get gimpplugindir"
+ elif [ -x /usr/bin/gimptool-2.0 ]; then
+ plugindir="$(gimptool-2.0 --gimpplugindir)/plug-ins" || die "Failed to get gimpplugindir"
+ else
+ die "Can't find GIMP plugin directory."
+ fi
+ dodir "${plugindir}"
+ dosym /usr/bin/iscan "${plugindir}"/iscan
+ fi
+
+ # install desktop entry
+ if use X; then
+ make_desktop_entry iscan "Image Scan! for Linux ${PV}" scanner
+ fi
+}
+
+pkg_postinst() {
+ local i
+ local DLL_CONF="/etc/sane.d/dll.conf"
+ local EPKOWA_CONF="/etc/sane.d/epkowa.conf"
+
+ elog
+ if grep -q "^[ \t]*\<epkowa\>" ${DLL_CONF}; then
+ elog "Please edit ${EPKOWA_CONF} to suit your needs."
+ elif grep -q "\<epkowa\>" ${DLL_CONF}; then
+ elog "Hint: to enable the backend, add 'epkowa' to ${DLL_CONF}"
+ elog "Then edit ${EPKOWA_CONF} to suit your needs."
+ else
+ echo "epkowa" >> ${DLL_CONF}
+ elog "A new entry 'epkowa' was added to ${DLL_CONF}"
+ elog "Please edit ${EPKOWA_CONF} to suit your needs."
+ fi
+}