summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/kphotoalbum/kphotoalbum-4.6.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/kphotoalbum/kphotoalbum-4.6.2.ebuild')
-rw-r--r--media-gfx/kphotoalbum/kphotoalbum-4.6.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/kphotoalbum/kphotoalbum-4.6.2.ebuild b/media-gfx/kphotoalbum/kphotoalbum-4.6.2.ebuild
new file mode 100644
index 000000000000..d152debe26bf
--- /dev/null
+++ b/media-gfx/kphotoalbum/kphotoalbum-4.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="ar be bg bs ca ca@valencia cs da de el en_GB eo es et eu fi fr ga
+gl hi hne hr hu is it ja km lt mai mr nb nds nl nn pa pl pt pt_BR ro ru se sk
+sv tr ug uk vi zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE Photo Album is a tool for indexing, searching, and viewing images"
+HOMEPAGE="http://www.kphotoalbum.org/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +exif +face +geolocation +kipi +map +raw"
+
+REQUIRED_USE="map? ( exif )"
+
+COMMON_DEPEND="
+ >=dev-qt/qtsql-4.4:4[sqlite]
+ media-libs/phonon[qt4]
+ virtual/jpeg:0
+ exif? ( >=media-gfx/exiv2-0.17 )
+ face? ( >=media-libs/libkface-4.7.0 )
+ geolocation? ( $(add_kdeapps_dep marble) )
+ kipi? ( $(add_kdeapps_dep libkipi '' 4.9.58) )
+ map? ( >=media-libs/libkgeomap-4.7.0 )
+ raw? ( $(add_kdeapps_dep libkdcraw '' 4.9.58) )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ media-video/mplayer
+ kipi? ( >=media-plugins/kipi-plugins-4.7.0 )
+"
+
+DOCS=( ChangeLog README )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with exif Exiv2)
+ $(cmake-utils_use_with face Kface)
+ $(cmake-utils_use_with geolocation Marble)
+ $(cmake-utils_use_with kipi)
+ $(cmake-utils_use_with map KGeoMap)
+ $(cmake-utils_use_with raw Kdcraw)
+ )
+
+ kde4-base_src_configure
+}