summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-14 01:35:49 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-14 02:08:38 +0100
commit9c5b9dc59bfbe618bd9e066e884060b024c4c83d (patch)
tree80a8c7d73408039a70f87baacd80846ac97b0399 /media-gfx/libimagequant/files
parentdev-util/cmake: Removed old. (diff)
downloadgentoo-9c5b9dc59bfbe618bd9e066e884060b024c4c83d.tar.gz
gentoo-9c5b9dc59bfbe618bd9e066e884060b024c4c83d.tar.bz2
gentoo-9c5b9dc59bfbe618bd9e066e884060b024c4c83d.zip
media-gfx/libimagequant: bump to v2.12.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-gfx/libimagequant/files')
-rw-r--r--media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch25
-rw-r--r--media-gfx/libimagequant/files/libimagequant-2.12.2-respect-CFLAGS.patch17
2 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch b/media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch
new file mode 100644
index 000000000000..0b058fbecc23
--- /dev/null
+++ b/media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 2666b3d..ba58cf1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -133,7 +133,7 @@ ifeq ($(filter %clean %distclean, $(MAKECMDGOALS)), )
+ endif
+
+ $(PKGCONFIG): config.mk
+- sed 's|PREFIX|$(PREFIX)|;s|VERSION|$(VERSION)|' < imagequant.pc.in > $(PKGCONFIG)
++ sed 's|PREFIX|$(PREFIX)|;s|VERSION|$(VERSION)|;s|LIBDIR|$(LIBDIR)|' < imagequant.pc.in > $(PKGCONFIG)
+
+ .PHONY: all static shared clean dist distclean dll java cargo
+ .DELETE_ON_ERROR:
+diff --git a/imagequant.pc.in b/imagequant.pc.in
+index 980da8c..6c6569d 100644
+--- a/imagequant.pc.in
++++ b/imagequant.pc.in
+@@ -1,6 +1,6 @@
+ prefix=PREFIX
+ includedir=${prefix}/include
+-libdir=${prefix}/lib
++libdir=LIBDIR
+
+ Name: imagequant
+ Description: Small, portable C library for high-quality conversion of RGBA images to 8-bit indexed-color (palette) images.
diff --git a/media-gfx/libimagequant/files/libimagequant-2.12.2-respect-CFLAGS.patch b/media-gfx/libimagequant/files/libimagequant-2.12.2-respect-CFLAGS.patch
new file mode 100644
index 000000000000..c290af36fe5f
--- /dev/null
+++ b/media-gfx/libimagequant/files/libimagequant-2.12.2-respect-CFLAGS.patch
@@ -0,0 +1,17 @@
+--- a/configure
++++ b/configure
+@@ -152,12 +152,12 @@ rm -f pngquant-gcccheck pngquant-gcccheck.c
+ status "Compiler" "$CC"
+
+ # init flags
+-CFLAGS=${CFLAGS:--fno-math-errno -funroll-loops -fomit-frame-pointer -Wall}
++CFLAGS=${CFLAGS:--fno-math-errno -funroll-loops -fomit-frame-pointer}
+ cflags "-std=c99 -I."
+
+ # DEBUG
+ if [ -z "$DEBUG" ]; then
+- cflags "-O3 -DNDEBUG"
++ cflags "-DNDEBUG"
+ status "Debug" "no"
+ else
+ cflags "-O1 -g"