summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-20 13:54:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-20 14:24:51 +0200
commit1ad32a5cbbbae69877bb1db250ccfcaa7545dd45 (patch)
tree582ffefe344ee94ab1fd2794f4f58435082455d7 /media-gfx/librecad/librecad-2.1.3-r5.ebuild
parentnet-proxy/squid: Security cleanup (diff)
downloadgentoo-1ad32a5cbbbae69877bb1db250ccfcaa7545dd45.tar.gz
gentoo-1ad32a5cbbbae69877bb1db250ccfcaa7545dd45.tar.bz2
gentoo-1ad32a5cbbbae69877bb1db250ccfcaa7545dd45.zip
media-gfx/librecad: EAPI-7 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/librecad/librecad-2.1.3-r5.ebuild')
-rw-r--r--media-gfx/librecad/librecad-2.1.3-r5.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/media-gfx/librecad/librecad-2.1.3-r5.ebuild b/media-gfx/librecad/librecad-2.1.3-r5.ebuild
index 5bb715ffa4ee..b9ce27bf50ed 100644
--- a/media-gfx/librecad/librecad-2.1.3-r5.ebuild
+++ b/media-gfx/librecad/librecad-2.1.3-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit desktop qmake-utils
@@ -12,9 +12,11 @@ SRC_URI="https://github.com/LibreCAD/LibreCAD/archive/${PV/_/}.tar.gz -> ${P}.ta
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
IUSE="debug doc tools"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
RDEPEND="
dev-cpp/muParser
dev-libs/boost:=
@@ -23,16 +25,19 @@ RDEPEND="
dev-qt/qtprintsupport:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
- media-libs/freetype:2"
+ media-libs/freetype:2
+"
DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
dev-qt/qthelp:5
dev-qt/qtxml:5
"
S="${WORKDIR}/LibreCAD-${PV}"
-PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" "${FILESDIR}/${P}-gcc-9.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-qt-5.11.patch"
+ "${FILESDIR}/${P}-gcc-9.patch"
+)
src_configure() {
eqmake5 -r