summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-22 11:36:08 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-22 11:36:29 +0100
commit0022435d4704b2e41b89091b0229a77c79354ce0 (patch)
tree413b64e527b633b48e3841fa94a230b123e9b71e /media-gfx/libredwg
parentsys-apps/firejail: apply firecfg patch; misc cleanups (diff)
downloadgentoo-0022435d4704b2e41b89091b0229a77c79354ce0.tar.gz
gentoo-0022435d4704b2e41b89091b0229a77c79354ce0.tar.bz2
gentoo-0022435d4704b2e41b89091b0229a77c79354ce0.zip
media-gfx/libredwg: 0.12.5: fix install of perl bindings
This broke because we moved from the release tarball to the tagged tarball Closes: https://bugs.gentoo.org/833881 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-gfx/libredwg')
-rw-r--r--media-gfx/libredwg/libredwg-0.12.5.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/media-gfx/libredwg/libredwg-0.12.5.ebuild b/media-gfx/libredwg/libredwg-0.12.5.ebuild
index 0d74bb5e092f..8f14bdef8e11 100644
--- a/media-gfx/libredwg/libredwg-0.12.5.ebuild
+++ b/media-gfx/libredwg/libredwg-0.12.5.ebuild
@@ -55,6 +55,8 @@ src_unpack() {
src_prepare() {
default
+ # Fix variable references itself error, fails in src_install otherwise.
+ sed -i -e 's/TEXINPUTS="$(TEXINPUTS)$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/TEXINPUTS="$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/g' doc/Makefile.am || die
# https://github.com/LibreDWG/libredwg/issues/404
# Workaround: release tarball does not include dwg2ps.1.
# Upstream autotools stuff has to be run in git repo
@@ -89,11 +91,6 @@ src_configure() {
fi
econf ${myconf[@]}
-
- # Fix variable references itself error, fails in src_install otherwise.
- # Can't put this in src_prepare and use eautoreconf because eautoreconf
- # only works inside a git repository for this package.
- sed -i -e 's/TEXINPUTS = "$(TEXINPUTS)$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/TEXINPUTS += "$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/g' doc/Makefile || die
}
src_compile() {
@@ -106,5 +103,4 @@ src_install() {
perl_set_version
default
use python && python_optimize
- use perl && perl_domodule bindings/perl/LibreDWG.pm
}