summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/nvidia-texture-tools/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/nvidia-texture-tools/files')
-rw-r--r--media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-cg.patch39
-rw-r--r--media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch18
-rw-r--r--media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-gcc-4.7.patch16
-rw-r--r--media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-openexr.patch93
4 files changed, 166 insertions, 0 deletions
diff --git a/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-cg.patch b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-cg.patch
new file mode 100644
index 000000000000..6dcb1b466944
--- /dev/null
+++ b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-cg.patch
@@ -0,0 +1,39 @@
+From: hasufell <hasufell@gentoo.org>
+Date: Thu May 3 20:06:31 UTC 2012
+
+fix compilation for cg useflag
+
+--- cmake/FindCg.cmake
++++ cmake/FindCg.cmake
+@@ -86,6 +86,7 @@
+ FIND_PROGRAM( CG_COMPILER cgc
+ /usr/bin
+ /usr/local/bin
++ /opt/nvidia-cg-toolkit/bin
+ DOC "The Cg Compiler"
+ )
+ GET_FILENAME_COMPONENT(CG_COMPILER_DIR "${CG_COMPILER}" PATH)
+@@ -93,6 +94,7 @@
+ FIND_PATH( CG_INCLUDE_PATH Cg/cg.h
+ /usr/include
+ /usr/local/include
++ /opt/nvidia-cg-toolkit/include
+ ${CG_COMPILER_SUPER_DIR}/include
+ DOC "The directory where Cg/cg.h resides"
+ )
+@@ -102,6 +104,7 @@
+ /usr/lib
+ /usr/local/lib64
+ /usr/local/lib
++ /opt/nvidia-cg-toolkit/lib
+ ${CG_COMPILER_SUPER_DIR}/lib64
+ ${CG_COMPILER_SUPER_DIR}/lib
+ DOC "The Cg runtime library"
+@@ -113,6 +116,7 @@
+ /usr/lib
+ /usr/local/lib64
+ /usr/local/lib
++ /opt/nvidia-cg-toolkit/lib
+ ${CG_COMPILER_SUPER_DIR}/lib64
+ ${CG_COMPILER_SUPER_DIR}/lib
+ DOC "The Cg runtime library"
diff --git a/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch
new file mode 100644
index 000000000000..373c87e4171b
--- /dev/null
+++ b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch
@@ -0,0 +1,18 @@
+Index: src/src/nvtt/squish/CMakeLists.txt
+===================================================================
+--- src/src/nvtt/squish/CMakeLists.txt (revision 13060)
++++ src/src/nvtt/squish/CMakeLists.txt (working copy)
+@@ -22,7 +22,11 @@
+
+ ADD_LIBRARY(squish STATIC ${SQUISH_SRCS})
+
+-IF(CMAKE_COMPILER_IS_GNUCXX)
++IF("${CMAKE_CXX_COMPILER}" MATCHES "clang(\\+\\+)?$" OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
++ SET(CMAKE_COMPILER_IS_CLANGXX 1)
++ENDIF()
++
++IF(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_CLANGXX)
+ SET_TARGET_PROPERTIES(squish PROPERTIES COMPILE_FLAGS -fPIC)
+-ENDIF(CMAKE_COMPILER_IS_GNUCXX)
++ENDIF(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_CLANGXX)
+
diff --git a/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-gcc-4.7.patch b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-gcc-4.7.patch
new file mode 100644
index 000000000000..62f33e905bfd
--- /dev/null
+++ b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-gcc-4.7.patch
@@ -0,0 +1,16 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jun 29 08:15:12 UTC 2012
+Subject: fix compilation on gcc 4.7
+
+https://bugs.gentoo.org/show_bug.cgi?id=423965
+
+--- src/nvcore/nvcore.h
++++ src/nvcore/nvcore.h
+@@ -158,6 +158,7 @@
+ #elif NV_CC_GNUC
+ # if NV_OS_LINUX
+ # include "DefsGnucLinux.h"
++# include <unistd.h> // gcc 4.7
+ # elif NV_OS_DARWIN
+ # include "DefsGnucDarwin.h"
+ # elif NV_OS_MINGW
diff --git a/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-openexr.patch b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-openexr.patch
new file mode 100644
index 000000000000..b49abf9e5c32
--- /dev/null
+++ b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-openexr.patch
@@ -0,0 +1,93 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Mar 20 22:10:22 UTC 2013
+Subject: add pkgconfig checks
+
+https://bugs.gentoo.org/show_bug.cgi?id=462494
+
+--- nvidia-texture-tools/cmake/FindOpenEXR.cmake
++++ nvidia-texture-tools/cmake/FindOpenEXR.cmake
+@@ -7,11 +7,15 @@
+ # OPENEXR_LIBRARIES = libraries that are needed to use OpenEXR.
+ #
+
+-INCLUDE(FindZLIB)
++IF(UNIX)
++ INCLUDE(FindPkgConfig)
++ pkg_check_modules(_PKG_OPENEXR OpenEXR)
++ENDIF(UNIX)
+
++find_package(ZLIB REQUIRED)
+
+-IF(ZLIB_FOUND)
+-
++IF(NOT _PKG_OPENEXR_FOUND)
++
+ SET(LIBRARY_PATHS
+ /usr/lib
+ /usr/local/lib
+@@ -46,10 +50,20 @@
+ NAMES IlmThread
+ PATHS ${LIBRARY_PATHS})
+
+-ENDIF(ZLIB_FOUND)
++ENDIF(NOT _PKG_OPENEXR_FOUND)
+
+ #MESSAGE(STATUS ${OPENEXR_IMATH_LIBRARY} ${OPENEXR_ILMIMF_LIBRARY} ${OPENEXR_IEX_LIBRARY} ${OPENEXR_HALF_LIBRARY} ${OPENEXR_ILMTHREAD_LIBRARY} ${ZLIB_LIBRARY})
+
++IF(_PKG_OPENEXR_FOUND)
++ SET(OPENEXR_FOUND TRUE)
++ foreach(i ${_PKG_OPENEXR_CFLAGS})
++ SET(OPENEXR_CFLAGS "${OPENEXR_CFLAGS} ${i}")
++ endforeach(i)
++ foreach(p ${_PKG_OPENEXR_LDFLAGS})
++ SET(OPENEXR_LDFLAGS "${OPENEXR_LDFLAGS} ${p}")
++ endforeach(p)
++ SET(OPENEXR_LDFLAGS "${OPENEXR_LDFLAGS} ${ZLIB_LIBRARY}")
++ELSE(_PKG_OPENEXR_FOUND)
+ IF (OPENEXR_INCLUDE_PATH AND OPENEXR_IMATH_LIBRARY AND OPENEXR_ILMIMF_LIBRARY AND OPENEXR_IEX_LIBRARY AND OPENEXR_HALF_LIBRARY)
+ SET(OPENEXR_FOUND TRUE)
+ SET(OPENEXR_INCLUDE_PATHS ${OPENEXR_INCLUDE_PATH} CACHE STRING "The include paths needed to use OpenEXR")
+@@ -65,6 +79,8 @@
+ MESSAGE(FATAL_ERROR "Could not find OpenEXR library")
+ ENDIF(OPENEXR_FIND_REQUIRED)
+ ENDIF(OPENEXR_FOUND)
++ENDIF(_PKG_OPENEXR_FOUND)
++
+
+ MARK_AS_ADVANCED(
+ OPENEXR_INCLUDE_PATHS
+@@ -73,3 +89,4 @@
+ OPENEXR_IMATH_LIBRARY
+ OPENEXR_IEX_LIBRARY
+ OPENEXR_HALF_LIBRARY)
++
+--- nvidia-texture-tools/src/nvimage/CMakeLists.txt
++++ nvidia-texture-tools/src/nvimage/CMakeLists.txt
+@@ -44,10 +44,10 @@
+ INCLUDE_DIRECTORIES(${TIFF_INCLUDE_DIR})
+ ENDIF(TIFF_FOUND)
+
+-IF(OPENEXR_FOUND)
++IF(OPENEXR_FOUND AND NOT _PKG_OPENEXR_FOUND)
+ SET(LIBS ${LIBS} ${OPENEXR_LIBRARIES})
+ INCLUDE_DIRECTORIES(${OPENEXR_INCLUDE_PATHS})
+-ENDIF(OPENEXR_FOUND)
++ENDIF(OPENEXR_FOUND AND NOT _PKG_OPENEXR_FOUND)
+
+ # targets
+ ADD_DEFINITIONS(-DNVIMAGE_EXPORTS)
+@@ -61,6 +61,14 @@
+
+ TARGET_LINK_LIBRARIES(nvimage ${LIBS} nvcore nvmath posh)
+
++IF(_PKG_OPENEXR_FOUND)
++ SET_TARGET_PROPERTIES(nvimage
++ PROPERTIES
++ COMPILE_FLAGS "${OPENEXR_CFLAGS}"
++ LINK_FLAGS "${OPENEXR_LDFLAGS}"
++ )
++ENDIF(_PKG_OPENEXR_FOUND)
++
+ INSTALL(TARGETS nvimage
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib