summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/openmesh/openmesh-3.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/openmesh/openmesh-3.3.ebuild')
-rw-r--r--media-gfx/openmesh/openmesh-3.3.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/openmesh/openmesh-3.3.ebuild b/media-gfx/openmesh/openmesh-3.3.ebuild
new file mode 100644
index 000000000000..df9aafcccc8c
--- /dev/null
+++ b/media-gfx/openmesh/openmesh-3.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils cmake-utils
+
+MY_PN="OpenMesh"
+MY_PV="${PV/_rc/-RC}"
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A generic and efficient data structure for representing and manipulating polygonal meshes"
+HOMEPAGE="http://www.openmesh.org/"
+SRC_URI="http://openmesh.org/media/Releases/${MY_PV/-RC/RC}/${MY_PN}-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="qt4 qt5 static-libs test"
+
+RDEPEND="
+ qt4? ( dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ media-libs/freeglut )
+ qt5? ( dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ media-libs/freeglut )"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+
+src_prepare() {
+ # Fix libdir and remove rpath.
+ sed -i \
+ -e "s|\(set (ACG_PROJECT_LIBDIR \"\).*|\1$(get_libdir)/\")|" \
+ -e "s|\(set (ACG_PROJECT_PLUGINDIR \"\)lib\(.*\)|\1$(get_libdir)\2|" \
+ -e "s|\(BUILD_WITH_INSTALL_RPATH \)1|\1 0|" \
+ -e "s|\(SKIP_BUILD_RPATH\) 0|\1 1|" \
+ -e '/^ *INSTALL_RPATH/d' \
+ cmake/ACGCommon.cmake || die
+
+ if ! use static-libs; then
+ sed -i "s|\(SHARED\)ANDSTATIC|\1|" \
+ src/${MY_PN}/{Core,Tools}/CMakeLists.txt || die
+ sed -i '/OpenMeshCoreStatic/d' \
+ src/${MY_PN}/Tools/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=""
+
+ mycmakeargs="${mycmakeargs} -DOPENMESH_BUILD_UNIT_TESTS=TRUE"
+
+ # Disable python bindings until someone wants them.
+ mycmakeargs="${mycmakeargs} -DOPENMESH_BUILD_PYTHON_BINDINGS=FALSE"
+ mycmakeargs="${mycmakeargs} -DOPENMESH_BUILD_PYTHON_UNIT_TESTS=FALSE"
+
+ if ! use qt4 && ! use qt5; then
+ mycmakeargs="${mycmakeargs} -DBUILD_APPS=OFF"
+ fi
+
+ if use qt4 && ! use qt5; then
+ mycmakeargs="${mycmakeargs} -DFORCE_QT4=ON"
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc LICENSE/* README CHANGELOG
+}