summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/panini
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/panini')
-rw-r--r--media-gfx/panini/Manifest1
-rw-r--r--media-gfx/panini/files/panini-0.71.104-glu.patch10
-rw-r--r--media-gfx/panini/files/panini.desktop10
-rw-r--r--media-gfx/panini/metadata.xml8
-rw-r--r--media-gfx/panini/panini-0.71.104.ebuild37
5 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/panini/Manifest b/media-gfx/panini/Manifest
new file mode 100644
index 000000000000..70cdcecb0390
--- /dev/null
+++ b/media-gfx/panini/Manifest
@@ -0,0 +1 @@
+DIST Panini-0.71.104-src.zip 602843 SHA256 aacd27a71049c5e3b953afc02ecd67fb9bfd35702255ff5cc21a96719c0c82b3 SHA512 506047cbaf6928ee234ad1071b4aeefeec43dc7cfe7640db796d25c4932521ed19c8adb3983dc00e31595e4ce87c38d65f88903f1756bbae2ce0b19843680737 WHIRLPOOL c39ef654e9967cf531376059e33ed3026dc39226753512c105f9089a845888b48a0a16b4bd923dbc7f131be5dce86f2dec48e39476055eeb554a198827f5099c
diff --git a/media-gfx/panini/files/panini-0.71.104-glu.patch b/media-gfx/panini/files/panini-0.71.104-glu.patch
new file mode 100644
index 000000000000..e9866161ae10
--- /dev/null
+++ b/media-gfx/panini/files/panini-0.71.104-glu.patch
@@ -0,0 +1,10 @@
+--- Panini-0.71.104-src/panini.pro
++++ Panini-0.71.104-src/panini.pro
+@@ -3,6 +3,7 @@
+ TARGET = Panini
+ CONFIG += debug_and_release
+ QT = gui core opengl
++LIBS += -lGLU -lz
+
+ # # Directories ##
+ OBJECTS_DIR = build
diff --git a/media-gfx/panini/files/panini.desktop b/media-gfx/panini/files/panini.desktop
new file mode 100644
index 000000000000..cffd55d5a02a
--- /dev/null
+++ b/media-gfx/panini/files/panini.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Panini
+GenericName=Panini perspective tool
+Comment=Perspective views from panoramic images
+Exec=panini %f
+Terminal=false
+Type=Application
+Icon=panini
+Categories=Graphics;
+MimeType=video/quicktime;image/jpeg;image/tiff;image/png;
diff --git a/media-gfx/panini/metadata.xml b/media-gfx/panini/metadata.xml
new file mode 100644
index 000000000000..8f3639ff8807
--- /dev/null
+++ b/media-gfx/panini/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">pvqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/panini/panini-0.71.104.ebuild b/media-gfx/panini/panini-0.71.104.ebuild
new file mode 100644
index 000000000000..9a6d10a42800
--- /dev/null
+++ b/media-gfx/panini/panini-0.71.104.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2 eutils
+
+MY_P="${P/p/P}-src"
+DESCRIPTION="OpenGL-based panoramic image viewer"
+HOMEPAGE="http://sourceforge.net/projects/pvqt/"
+SRC_URI="mirror://sourceforge/pvqt/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtopengl:4
+ virtual/glu
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glu.patch
+}
+
+src_install() {
+ newbin Panini panini
+ dodoc panini-usage.txt panini-0.71-release.txt
+ domenu "${FILESDIR}"/${PN}.desktop
+ newicon ui/panini-icon-blue.jpg ${PN}.jpg
+}