summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/photivo/photivo-0_pre20121006.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/photivo/photivo-0_pre20121006.ebuild')
-rw-r--r--media-gfx/photivo/photivo-0_pre20121006.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-gfx/photivo/photivo-0_pre20121006.ebuild b/media-gfx/photivo/photivo-0_pre20121006.ebuild
new file mode 100644
index 000000000000..a958bcbb068d
--- /dev/null
+++ b/media-gfx/photivo/photivo-0_pre20121006.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="Photo processor for RAW and Bitmap images"
+HOMEPAGE="http://www.photivo.org"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gimp"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ virtual/jpeg
+ media-libs/tiff
+ media-libs/libpng
+ media-gfx/exiv2
+ media-libs/lcms:2
+ media-libs/lensfun
+ sci-libs/fftw:3.0
+ media-libs/liblqr
+ media-gfx/graphicsmagick[q16,-lcms]
+ media-gfx/greycstoration[lapack]
+ virtual/lapack
+ media-libs/cimg
+ gimp? ( media-gfx/gimp )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PV/0_pre/}
+
+src_prepare() {
+ # remove ccache dependency
+ local File
+ for File in $(find "${S}" -type f); do
+ if grep -sq ccache ${File}; then
+ sed -e 's/ccache//' -i "${File}"
+ fi
+ done
+
+ # useless check (no pkgconfig file is provided)
+ sed -e "/PKGCONFIG += CImg/d" \
+ -i photivoProject/photivoProject.pro || die
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local config="WithSystemCImg"
+ if ! use gimp ; then
+ config+=" WithoutGimp"
+ fi
+
+ eqmake4 "CONFIG+=${config}"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use gimp; then
+ exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
+ doexe ptGimp
+ doexe "mm extern photivo.py"
+ fi
+}